summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-04-27 21:41:52 -0400
committerJean Lucas2019-04-27 21:45:23 -0400
commit53592491b6d89befbb3b3f58a9a9b2a11d052744 (patch)
tree3ee43d3d97cf4a5b032bf71c04fb385564f9d5ed
downloadaur-53592491b6d89befbb3b3f58a9a9b2a11d052744.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD44
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e22f279e5de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Sun Apr 28 01:41:28 UTC 2019
+pkgbase = redshift-wlr-gamma-control
+ pkgdesc = Redshift fork supporting color temperature adjustment with wlroots
+ pkgver = 1.12+25+geecbfed
+ pkgrel = 1
+ url = https://github.com/minus7/redshift/tree/wayland
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = intltool
+ makedepends = python
+ makedepends = wayland
+ depends = geoclue2
+ depends = libdrm
+ depends = libxcb
+ depends = libxxf86vm
+ optdepends = python-gobject: for redshift-gtk
+ optdepends = python-xdg: for redshift-gtk
+ optdepends = gtk3: for redshift-gtk
+ optdepends = sway: Wayland environment with wlr-gamma-control protocol
+ provides = redshift
+ conflicts = redshift
+ conflicts = redshift-wlr-gamma-control-git
+ source = git+https://github.com/minus7/redshift#commit=eecbfedac48f827e96ad5e151de8f41f6cd3af66
+ sha512sums = SKIP
+
+pkgname = redshift-wlr-gamma-control
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb3ceac77dac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=redshift-wlr-gamma-control
+pkgver=1.12+25+geecbfed
+_commit=eecbfedac48f827e96ad5e151de8f41f6cd3af66
+pkgrel=1
+pkgdesc="Redshift fork supporting color temperature adjustment with wlroots"
+arch=(i686 x86_64)
+url=https://github.com/minus7/redshift/tree/wayland
+license=(GPL3)
+provides=(redshift)
+conflicts=(redshift redshift-wlr-gamma-control-git)
+depends=(geoclue2 libdrm libxcb libxxf86vm)
+optdepends=('python-gobject: for redshift-gtk'
+ 'python-xdg: for redshift-gtk'
+ 'gtk3: for redshift-gtk'
+ 'sway: Wayland environment with wlr-gamma-control protocol')
+makedepends=(git intltool python wayland)
+source=(git+${url/\/tree*/}#commit=$_commit)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd redshift
+ git describe --long --tags | sed 's/v//;s/-/+/g'
+}
+
+build() {
+ cd redshift
+ ./bootstrap
+ ./configure \
+ --prefix=/usr \
+ --enable-drm \
+ --enable-randr \
+ --enable-vidmode \
+ --enable-geoclue2 \
+ --enable-wayland \
+ --with-systemduserunitdir=/usr/lib/systemd/user
+ make
+}
+
+package() {
+ cd redshift
+ make DESTDIR="$pkgdir" install
+}