summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-08-15 18:47:45 -0400
committerJean Lucas2019-08-15 18:47:45 -0400
commitc5f16df8a0eec5d2a3ee80067f89b9f3b4c68eb5 (patch)
tree160f9e7093468e96eff1c795c36e2de847fb08e1
parent2be7ab16469185d9146a78874f891eab4d95a17e (diff)
downloadaur-c5f16df8a0eec5d2a3ee80067f89b9f3b4c68eb5.tar.gz
Update deps, pkgver schema; install license
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98b8947ceece..1d3e7d31b3ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
pkgbase = redshift-wlr-gamma-control
pkgdesc = Redshift fork supporting color temperature adjustment with wlroots
- pkgver = 1.12+25+geecbfed
- pkgrel = 2
+ pkgver = 1.12+r25+geecbfed
+ pkgrel = 1
url = https://github.com/minus7/redshift/tree/wayland
arch = i686
arch = x86_64
license = GPL3
makedepends = git
makedepends = intltool
- makedepends = python
- makedepends = wayland
- depends = geoclue2
+ depends = glib2
+ depends = hicolor-icon-theme
depends = libdrm
- depends = libxcb
depends = libxxf86vm
+ depends = python
+ depends = wayland
optdepends = python-gobject: for redshift-gtk
- optdepends = python-xdg: for redshift-gtk
optdepends = gtk3: for redshift-gtk
- optdepends = sway: Wayland environment with wlr-gamma-control protocol
+ optdepends = geoclue: for geolocation support
+ optdepends = sway: Wayland environment using the wlr-gamma-control protocol
provides = redshift
conflicts = redshift
source = git+https://github.com/minus7/redshift#commit=eecbfedac48f827e96ad5e151de8f41f6cd3af66
diff --git a/PKGBUILD b/PKGBUILD
index c4ba014724f1..66b34b48d5c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=redshift-wlr-gamma-control
-pkgver=1.12+25+geecbfed
+pkgver=1.12+r25+geecbfed
_commit=eecbfedac48f827e96ad5e151de8f41f6cd3af66
-pkgrel=2
-pkgdesc="Redshift fork supporting color temperature adjustment with wlroots"
+pkgrel=1
+pkgdesc='Redshift fork supporting color temperature adjustment with wlroots'
arch=(i686 x86_64)
url=https://github.com/minus7/redshift/tree/wayland
license=(GPL3)
-provides=(redshift)
-conflicts=(redshift)
-depends=(geoclue2 libdrm libxcb libxxf86vm)
+depends=(glib2 hicolor-icon-theme libdrm libxxf86vm python wayland)
+makedepends=(git intltool)
optdepends=('python-gobject: for redshift-gtk'
- 'python-xdg: for redshift-gtk'
'gtk3: for redshift-gtk'
- 'sway: Wayland environment with wlr-gamma-control protocol')
-makedepends=(git intltool python wayland)
+ 'geoclue: for geolocation support'
+ 'sway: Wayland environment using the wlr-gamma-control protocol')
+provides=(redshift)
+conflicts=(redshift)
source=(git+${url/\/tree*/}#commit=$_commit)
sha512sums=('SKIP')
pkgver() {
cd redshift
- git describe --long --tags | sed 's/v//;s/-/+/g'
+ git describe --long --tags | sed 's#v##;s#-#+#g;s#+#+r#'
}
build() {
@@ -41,4 +41,5 @@ build() {
package() {
cd redshift
make DESTDIR="$pkgdir" install
+ install -Dm 644 COPYING -t "$pkgdir"/usr/share/licenses/redshift
}