summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgilcu32021-02-19 00:40:24 +0100
committergilcu32021-02-19 00:40:24 +0100
commitb9368b4edccf806eb6a5905435e0a4e6c182fcb4 (patch)
tree3c2841750e46b4d769f2b5bbbb2fdde13dae4430
parentacfdbb8f6313ca899c536e45f0975e70e5d0d6a6 (diff)
downloadaur-b9368b4edccf806eb6a5905435e0a4e6c182fcb4.tar.gz
now using original redsocks2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e26a055ef58a..cbf5eeda81d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = redsocks2-git
- pkgdesc = redsocks2 adapted to compile with openssl 1.0
- pkgver = 0.67.r10.gbf24acf
+ pkgdesc = redsocks2
+ pkgver = 0.67.r36.g1951b49
pkgrel = 1
url = https://github.com/semigodking/redsocks
install = redsocks2.install
@@ -14,7 +14,7 @@ pkgbase = redsocks2-git
backup = etc/conf.d/redsocks2
backup = etc/iptables/redsocks2.rules
backup = etc/redsocks2.conf
- source = redsocks2-git::git+https://github.com/gilcu3/redsocks.git
+ source = git+https://github.com/semigodking/redsocks.git
source = redsocks2.tmpfiles
source = redsocks2.rules
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ec1852bcd8e8..f689b1792616 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
-# Maintainer: gilcu3 <gilcu3@gmail.com>
+# Maintainer: gilcu3 <gilcu3 [at] gmail [dot] com>
# Contributor: mortzu <me@mortzu.de>
# Contributor: David Manouchehri <d@32t.ca>
# Submitter: fluffylime <fluffylime@gmail.com>
-pkgname=redsocks2-git
-pkgver=0.67.r10.gbf24acf
+_pkgname=redsocks
+pkgname=${_pkgname}2-git
+pkgver=0.67.r36.g1951b49
pkgrel=1
-pkgdesc='redsocks2 adapted to compile with openssl 1.0'
+pkgdesc='redsocks2'
arch=('i686' 'x86_64')
url='https://github.com/semigodking/redsocks'
license=('GPL3')
@@ -18,8 +19,7 @@ install=redsocks2.install
backup=('etc/conf.d/redsocks2'
'etc/iptables/redsocks2.rules'
'etc/redsocks2.conf')
-
-source=("$pkgname"::'git+https://github.com/gilcu3/redsocks.git'
+source=("git+$url.git"
'redsocks2.tmpfiles'
'redsocks2.rules')
md5sums=('SKIP'
@@ -27,27 +27,26 @@ md5sums=('SKIP'
'04702a7faf31d707d3df4c116bd58a6d')
pkgver() {
- cd "$pkgname"
+ cd "$_pkgname"
- # git describe | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/release.//g'
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/release.//g'
}
build() {
- cd "$pkgname"
+ cd "$_pkgname"
make DISABLE_SHADOWSOCKS=true
}
package() {
- cd "$pkgname"
+ cd "$_pkgname"
- install -Dm644 "$srcdir/$pkgname/redsocks2.conf.example" "$pkgdir/etc/redsocks2.conf"
+ install -Dm644 "$srcdir/$_pkgname/redsocks.conf.example" "$pkgdir/etc/redsocks2.conf"
install -Dm644 "$srcdir/redsocks2.rules" "$pkgdir/etc/iptables/redsocks2.rules"
install -Dm644 "$srcdir/redsocks2.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/redsocks2.conf"
install -Dm755 "redsocks2" "$pkgdir/usr/bin/redsocks2"
install -Dm644 "README" "$pkgdir/usr/share/doc/redsocks2/README"
install -Dm644 "redsocks2.service" "$pkgdir/usr/lib/systemd/system/redsocks2.service"
- install -Dm644 "redsocks2.conf.example" "$pkgdir/usr/share/doc/redsocks2/redsocks2.conf.example"
+ install -Dm644 "redsocks.conf.example" "$pkgdir/usr/share/doc/redsocks2/redsocks2.conf.example"
}