summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Hicken2016-09-15 15:47:55 +0200
committerJan Hicken2016-09-15 15:47:55 +0200
commitdf472fc03c4573d632eb3be8375ff9928bd29cb9 (patch)
tree298f22268c95e92d47cf1f3aa029cfae15ab8ed9
downloadaur-df472fc03c4573d632eb3be8375ff9928bd29cb9.tar.gz
Initial commit.
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD52
-rw-r--r--redtimer.desktop9
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8dc5d2492b37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu Sep 15 13:47:55 UTC 2016
+pkgbase = redtimer-git
+ pkgdesc = RedTimer is an easy-to-use platform-independent time tracker which allows the user to track time while working on an issue
+ pkgver = v1.1.1.r41.gf50900b
+ pkgrel = 1
+ url = https://github.com/fathomssen/redtimer
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = hicolor-icon-theme
+ depends = qt5-quickcontrols
+ depends = qt5-quickcontrols2
+ depends = qt5-svg
+ depends = qt5-x11extras
+ source = git+https://github.com/fathomssen/redtimer.git
+ source = redtimer.desktop
+ sha256sums = SKIP
+ sha256sums = 3cbea017afa71e4bb21a941b01ce6e558897a974fefbdb7f8382a6bd3bf4194b
+
+pkgname = redtimer-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5954461c80a9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+# makepkg folders
+src/
+pkg/
+
+# built packages
+*.pkg*
+
+# sources
+*.tar.gz
+redtimer/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51f0e4af345f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Jan Hicken <jan.hicken@posteo.de>
+pkgname=redtimer-git
+_gitroot=fathomssen
+_gitname=redtimer
+pkgver=v1.1.1.r41.gf50900b
+pkgrel=1
+pkgdesc="RedTimer is an easy-to-use platform-independent time tracker which allows the user to track time while working on an issue"
+arch=(i686 x86_64)
+url="https://github.com/fathomssen/redtimer"
+license=('LGPL')
+depends=('hicolor-icon-theme' 'qt5-quickcontrols' 'qt5-quickcontrols2' 'qt5-svg' 'qt5-x11extras')
+makedepends=('git')
+source=("git+https://github.com/$_gitroot/$_gitname.git"
+ "${_gitname}.desktop")
+sha256sums=('SKIP'
+ '3cbea017afa71e4bb21a941b01ce6e558897a974fefbdb7f8382a6bd3bf4194b')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$_gitname"
+ git submodule update --init
+}
+
+build() {
+ cd "$_gitname"
+
+ qmake -r
+ make
+}
+
+package() {
+ install -Dm0644 "${_gitname}.desktop" "${pkgdir}/usr/share/applications/${_gitname}.desktop"
+
+ cd "$_gitname"
+ install -Dm0644 "client/icons/clock_red.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_gitname}.svg"
+
+ install -D "client/RedTimerClient" "${pkgdir}/usr/bin/${_gitname}"
+ install -D "libqtredmine/libqtredmine.so.1.0.0" "${pkgdir}/usr/lib/libqtredmine.so.1.0.0"
+ ln -s "libqtredmine.so.1.0.0" "${pkgdir}/usr/lib/libqtredmine.so.1.0"
+ ln -s "libqtredmine.so.1.0.0" "${pkgdir}/usr/lib/libqtredmine.so.1"
+ ln -s "libqtredmine.so.1.0.0" "${pkgdir}/usr/lib/libqtredmine.so."
+ install -D "libredtimer/libredtimer.so.1.0.0" "${pkgdir}/usr/lib/libredtimer.so.1.0.0"
+ ln -s "libredtimer.so.1.0.0" "${pkgdir}/usr/lib/libredtimer.so.1.0"
+ ln -s "libredtimer.so.1.0.0" "${pkgdir}/usr/lib/libredtimer.so.1"
+ ln -s "libredtimer.so.1.0.0" "${pkgdir}/usr/lib/libredtimer.so"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/redtimer.desktop b/redtimer.desktop
new file mode 100644
index 000000000000..5e12733609cf
--- /dev/null
+++ b/redtimer.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=RedTimer
+GenericName=Redmine Time Tricker
+Comment=RedTimer is an easy-to-use platform-independent time tracker which allows the user to track time while working on an issue
+Exec=redtimer
+Icon=redtimer
+Terminal=false
+Type=Application
+Categories=Development