summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornl67202016-09-23 18:33:46 +0300
committernl67202016-09-23 18:33:46 +0300
commitfd2be86bd0160cac1789f43fcddcf8b6a9e4b22d (patch)
tree7cb7f134b2e75467aa976f2bec72b777102d44bc
parent09b071cfe432de007dd9420f7787c396da093e10 (diff)
downloadaur-fd2be86bd0160cac1789f43fcddcf8b6a9e4b22d.tar.gz
Improve PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD65
2 files changed, 12 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac4ce54d037d..d738df0f0ba8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,19 +12,17 @@ pkgbase = refind-efi-git
depends = bash
depends = dosfstools
depends = efibootmgr
- optdepends = mactel-boot: For bless command in Apple Mac systems
optdepends = imagemagick: For refind-mkfont script
optdepends = python: For refind-mkdefault script
- provides = refind=0.10.3.r491.508d890
provides = refind-efi=0.10.3.r491.508d890
conflicts = refind-efi
options = !strip
- options = docs
+ options = !buildflags
options = !makeflags
source = refind::git+http://git.code.sf.net/p/refind/code#branch=master
source = refind_linux.conf
- sha1sums = SKIP
- sha1sums = b6bc8653eb15a650b557db177378e65f6cbd52a3
+ sha256sums = SKIP
+ sha256sums = 098b703516cf10ffcc21193af7524a72c347970471a5e839dd1a79f65f81d763
pkgname = refind-efi-git
diff --git a/PKGBUILD b/PKGBUILD
index 62c11fd884d6..7e674f540b6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,20 +26,22 @@ license=('GPL3' 'custom')
makedepends=('git')
depends=('bash' 'dosfstools' 'efibootmgr')
-optdepends=('mactel-boot: For bless command in Apple Mac systems'
- 'imagemagick: For refind-mkfont script'
+optdepends=('imagemagick: For refind-mkfont script'
'python: For refind-mkdefault script')
-options=('!strip' 'docs' '!makeflags')
+options=('!strip' '!buildflags' '!makeflags')
-conflicts=('refind-efi')
-provides=("refind=${pkgver}" "refind-efi=${pkgver}")
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}=${pkgver}")
install="${_pkgname}.install"
source=("refind::git+http://git.code.sf.net/p/refind/code#branch=master"
'refind_linux.conf')
+sha256sums=('SKIP'
+ '098b703516cf10ffcc21193af7524a72c347970471a5e839dd1a79f65f81d763')
+
if [[ "${_USE_GNU_EFI}" == '1' ]]; then
pkgdesc="${pkgdesc} - Built with GNU-EFI libs"
@@ -64,17 +66,11 @@ else
fi
-sha1sums=('SKIP'
- 'b6bc8653eb15a650b557db177378e65f6cbd52a3')
-
pkgver() {
cd "${srcdir}/${__pkgname}/"
- _ACTUAL_REFIND_VER="$(grep -o 'REFIND_VERSION=.*' "${srcdir}/${__pkgname}/Makefile" | grep -Eo '([0-9]|\.)+')"
- echo "${_ACTUAL_REFIND_VER}.$(printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)")"
-
- unset _ACTUAL_REFIND_VER
+ printf "%s.r%s.%s" "$(grep -o 'REFIND_VERSION=.*' "${srcdir}/${__pkgname}/Makefile" | grep -Eo '([0-9]|\.)+')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
@@ -155,7 +151,6 @@ _prepare_refind_sources() {
# Clean rEFInd git repo
git clean -x -d -f
- echo
if [[ "${_USE_GNU_EFI}" == '1' ]]; then
# Enable GNU_EFI_USE_MS_ABI
@@ -216,31 +211,14 @@ _build_tianocore_sources() {
cd "${_UDK_DIR}/"
- # Unset all compiler FLAGS
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
-
# Setup UDK Environment
source "${_UDK_DIR}/BaseTools/BuildEnv" BaseTools
- echo
# Compile UDK BaseTools
make -C "${EDK_TOOLS_PATH}"
- echo
-
- # Unset all compiler FLAGS
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
# Compile UDK Libraries
"${EDK_TOOLS_PATH}/BinWrappers/PosixLike/build" -p "${_UDK_TARGET}" -a "${_TIANO_ARCH}" -b "${_TIANOCORE_TARGET}" -t "${_COMPILER}"
- echo
}
@@ -252,48 +230,23 @@ build() {
cd "${srcdir}/${__pkgname}_build/"
- # Unset all compiler FLAGS
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
-
# Compile rEFInd UEFI application
if [[ "${_USE_GNU_EFI}" == '1' ]]; then
make gnuefi
- echo
else
make tiano
- echo
fi
- # Unset all compiler FLAGS
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
-
# Compile UEFI FS drivers
if [[ "${_USE_GNU_EFI}" == '1' ]]; then
make fs_gnuefi
- echo
else
- make fs
- echo
+ make fs_tiano
fi
if [[ "${CARCH}" == 'x86_64' ]] && [[ "${_PXE}" == '1' ]]; then
cd "${srcdir}/${__pkgname}_build/net"
- # Unset all compiler FLAGS
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
-
# Compile Network support
make source
make netboot