summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeromy Altuna2021-08-28 08:39:38 -0500
committerJeromy Altuna2021-08-28 08:39:38 -0500
commit9f9fd78bef8e91f1941a929a2270c3d203a6c368 (patch)
tree9fe91a9fcce96523a2c6cf00beeb4ba65318c5e1
downloadaur-9f9fd78bef8e91f1941a929a2270c3d203a6c368.tar.gz
Init: rEFInd theme
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
-rw-r--r--refind-theme-nord.install14
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e83cc20d3407
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = refind-theme-nord
+ pkgdesc = Simple theme inspired to the nord palette
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/jaltuna/refind-theme-nord
+ install = refind-theme-nord.install
+ arch = any
+ license = MIT
+ depends = refind
+ source = https://github.com/jaltuna/refind-theme-nord/releases/download/1.0.0/refind-theme-nord-1.0.0.tar.gz
+ sha256sums = 7dd33482adc9372fe10e4e549f48e9b31e934580ba29e88e20ab96de3374fb54
+
+pkgname = refind-theme-nord
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75a4576c2089
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jeromy Altuna <jaltuna at outlook dot es>
+
+pkgname=refind-theme-nord
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Simple theme inspired to the nord palette"
+arch=('any')
+url="https://github.com/jaltuna/refind-theme-nord"
+license=('MIT')
+depends=('refind')
+source=("${url}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('7dd33482adc9372fe10e4e549f48e9b31e934580ba29e88e20ab96de3374fb54')
+
+install=$pkgname.install
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ # do not reset the STDIN file descriptor
+ sed -e 's|exec|# exec|g' -i 'setup.sh'
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ _theme_dir="usr/share/refind/themes/nord"
+
+ install -D -m0755 -t "${pkgdir}/${_theme_dir}/" "setup.sh"
+ install -D -m0644 -t "${pkgdir}/${_theme_dir}/" {theme.conf,*.png}
+ install -D -m0644 -t "${pkgdir}/${_theme_dir}/icons" "icons/"*.png
+
+ # docs
+ install -D -m0644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
+ # licenses
+ install -D -m0644 -t "${pkgdir}/usr/share/licenses/${pkgname}" {LICENSE,COPYING}
+}
diff --git a/refind-theme-nord.install b/refind-theme-nord.install
new file mode 100644
index 000000000000..4630bccf3e04
--- /dev/null
+++ b/refind-theme-nord.install
@@ -0,0 +1,14 @@
+post_install() {
+ local install_dir='/usr/share/refind/themes/nord'
+
+ cd "$install_dir" || exit 1
+
+ echo "Setup refind-theme-nord-$1"
+ echo "Executing ${install_dir}/setup.sh..."
+
+ if ! bash setup.sh; then
+ echo "###########################################################"
+ echo "A problem occurred when running 'setup.sh', run it manually
+ echo "###########################################################"
+ fi
+}