summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Asuncion2016-11-29 18:54:55 -0800
committerJeremy Asuncion2016-11-29 18:54:55 -0800
commit41d9e51a5ee0225b21033488248f60e289c0edd5 (patch)
treedb79b7a191c5207e0225bfe5020d5efb941f504e
downloadaur-41d9e51a5ee0225b21033488248f60e289c0edd5.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..122587249bb3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = refind-theme-regular-git
+ pkgdesc = A simplistic clean and minimal theme for rEFInd
+ pkgver = r26.3e2f6ac
+ pkgrel = 1
+ url = https://github.com/munlik/refind-theme-regular
+ arch = any
+ license = AGPL3
+ license = custom:OFL
+ license = custom:Ubuntu Font License 1.0
+ makedepends = git
+ depends = refind-efi
+ source = git+https://github.com/munlik/refind-theme-regular
+ md5sums = SKIP
+
+pkgname = refind-theme-regular-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f309aa1071f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# vim: set ts=2 sw=2 sts=2 sta et :
+# Maintainer: Jeremy Asuncion <jeremyasuncion808@gmail.com>
+pkgname=refind-theme-regular-git
+pkgver=r26.3e2f6ac
+pkgrel=1
+pkgdesc="A simplistic clean and minimal theme for rEFInd"
+arch=(any)
+url="https://github.com/munlik/refind-theme-regular"
+license=('AGPL3' 'custom:OFL' 'custom:Ubuntu Font License 1.0')
+depends=('refind-efi')
+makedepends=('git')
+source=('git+https://github.com/munlik/refind-theme-regular')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ REFIND_HOME="${pkgdir}/boot/EFI/refind"
+
+ mkdir -p "${REFIND_HOME}"
+ cp -r "${srcdir}/${pkgname%-git}" "${REFIND_HOME}"
+ chmod -R 644 "${REFIND_HOME}/${pkgname%-git}"
+
+ echo 'Remember to add "include refind-theme-regular/theme.conf" to your refind.conf file'
+}