summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShatur952019-06-26 00:49:01 +0300
committerShatur952019-06-26 00:49:01 +0300
commite7cf3b66d2429285594531ea01c23006817f9382 (patch)
tree9c8c88eacc6e5d2ec764c4fa2cc5df75f15ed3aa
parent9730ea10019207aee0675429af6ea08816eacc29 (diff)
downloadaur-e7cf3b66d2429285594531ea01c23006817f9382.tar.gz
Use maintained fork by bobafetthotmail
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 122587249bb3..b704a307a861 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = refind-theme-regular-git
pkgdesc = A simplistic clean and minimal theme for rEFInd
- pkgver = r26.3e2f6ac
+ pkgver = r42.7a282d0
pkgrel = 1
- url = https://github.com/munlik/refind-theme-regular
+ url = https://github.com/bobafetthotmail/refind-theme-regular
arch = any
license = AGPL3
license = custom:OFL
license = custom:Ubuntu Font License 1.0
makedepends = git
depends = refind-efi
- source = git+https://github.com/munlik/refind-theme-regular
+ source = git+https://github.com/bobafetthotmail/refind-theme-regular
md5sums = SKIP
pkgname = refind-theme-regular-git
diff --git a/PKGBUILD b/PKGBUILD
index 3c7bab9090f3..d1beb41b4282 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,29 @@
# Maintainer: Jeremy Asuncion <jeremyasuncion808@gmail.com>
-
+
pkgname='refind-theme-regular-git'
-pkgver='r26.3e2f6ac'
+pkgver=r42.7a282d0
pkgrel=1
pkgdesc="A simplistic clean and minimal theme for rEFInd"
arch=('any')
-url="https://github.com/munlik/refind-theme-regular"
+url="https://github.com/bobafetthotmail/refind-theme-regular"
license=('AGPL3' 'custom:OFL' 'custom:Ubuntu Font License 1.0')
depends=('refind-efi')
makedepends=('git')
-source=('git+https://github.com/munlik/refind-theme-regular')
+source=('git+https://github.com/bobafetthotmail/refind-theme-regular')
md5sums=('SKIP')
-_name=${pkgname%-git}
-
pkgver() {
- cd "${srcdir}/${_name}"
+ cd "${pkgname%-git}"
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- local refind_home="${pkgdir}/boot/EFI/refind"
+ # Specify path to the refind directory
+ _refind_home="$pkgdir/boot/EFI/refind"
- mkdir -p "${refind_home}"
- cp -r "${srcdir}/${_name}" "${refind_home}"
- chmod -R 644 "${refind_home}/${_name}"
+ install -D "$srcdir/${pkgname%-git}/theme.conf" "$_refind_home/${pkgname%-git}/theme.conf"
+ cp -r "$srcdir/${pkgname%-git}/fonts" "$_refind_home/${pkgname%-git}"
+ cp -r "$srcdir/${pkgname%-git}/icons" "$_refind_home/${pkgname%-git}"
- echo 'Remember to add "include refind-theme-regular/theme.conf" to your refind.conf file'
+ warning 'To enable the theme add "include refind-theme-regular/theme.conf" at the end of refind.conf, and comment out or delete any other themes you might have installed.'
}