summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Rosenstrauch2018-06-21 09:44:43 -0400
committerDavid Rosenstrauch2018-06-21 09:44:43 -0400
commit82375fe22111f32e4c83b4e9a92e5450f64a33d4 (patch)
treeaf48c59a8d6dde61fe60530d4acb3afca90720a3
downloadaur-82375fe22111f32e4c83b4e9a92e5450f64a33d4.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66166db4f10b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = refind-theme-tux-git
+ pkgdesc = Ubuntu is nice but it needs a little Tux. Here he is, the man himself in the boot loader as a rEFInd theme.
+ pkgver = r85.e6c9f05
+ pkgrel = 1
+ url = https://github.com/pradyumnasagar/tux4ubuntu/tree/master/tux-refind-theme
+ arch = any
+ license = none
+ makedepends = git
+ depends = refind-efi
+ source = git+https://github.com/pradyumnasagar/tux4ubuntu.git
+ md5sums = SKIP
+
+pkgname = refind-theme-tux-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32eee80e3eef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: David Rosenstrauch <darose@darose.net>
+pkgname=refind-theme-tux-git
+pkgver=r85.e6c9f05
+pkgrel=1
+pkgdesc="Ubuntu is nice but it needs a little Tux. Here he is, the man himself in the boot loader as a rEFInd theme."
+arch=('any')
+url="https://github.com/pradyumnasagar/tux4ubuntu/tree/master/tux-refind-theme"
+license=('none')
+depends=('refind-efi')
+makedepends=('git')
+source=('git+https://github.com/pradyumnasagar/tux4ubuntu.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/tux4ubuntu"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ REFIND_HOME="${pkgdir}/boot/EFI/refind"
+
+ mkdir -p "${REFIND_HOME}/themes"
+ cp -r "${srcdir}/tux4ubuntu/tux-refind-theme/" "${REFIND_HOME}/themes/tux/"
+ chmod -R 644 "${REFIND_HOME}/themes/tux"
+
+ echo 'Remember to add "include themes/tux/theme.conf" to your refind.conf file'
+}