summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSilvio Knizek2015-11-10 12:00:12 +0100
committerSilvio Knizek2015-11-10 12:00:12 +0100
commit39dd79675ca2c56de06b44df93090daab1b3964f (patch)
treeed987157f33c983c73108438ef76aebabe3c570f
parent46dab53fa4fd461c64422687d6204ec0672cc852 (diff)
downloadaur-39dd79675ca2c56de06b44df93090daab1b3964f.tar.gz
move the default config out of /etc into /usr/share to support an empty /etc \(a file in /etc/conf.d can still overwrite the default settings\)\; don\'t autoenable the timer anymore\; make the timer enableable\; use the right timers.target
-rw-r--r--PKGBUILD8
-rw-r--r--reflector.service3
-rw-r--r--reflector.timer3
3 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3918e27fe40e..1aca76ae1de6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Silvio Knizek <killermoehre@gmx.net>
pkgname=reflector-timer
-pkgver=3
-pkgrel=3
+pkgver=4
+pkgrel=1
pkgdesc='A service and timer for the reflector mirrorlist upgrade.'
arch=('any')
url='http://xyne.archlinux.ca/projects/reflector/'
@@ -18,7 +18,5 @@ md5sums=('41d8e59e224200a41c256ca465454c29'
package() {
install -D -m 644 'reflector.service' "$pkgdir/usr/lib/systemd/system/reflector.service"
install -D -m 644 'reflector.timer' "$pkgdir/usr/lib/systemd/system/reflector.timer"
- install -D -m 644 'reflector.conf' "$pkgdir/etc/conf.d/reflector.conf"
- install -d -m 755 "${pkgdir}/usr/lib/systemd/system/multi-user.target.wants"
- ln -s "../reflector.timer" "${pkgdir}/usr/lib/systemd/system/multi-user.target.wants/reflector.timer"
+ install -D -m 644 'reflector.conf' "$pkgdir/usr/share/reflector-timer/reflector.conf"
}
diff --git a/reflector.service b/reflector.service
index b795491e36d0..02f985ee537b 100644
--- a/reflector.service
+++ b/reflector.service
@@ -4,5 +4,6 @@ Documentation=https://wiki.archlinux.org/index.php/Reflector
[Service]
Type=oneshot
-EnvironmentFile=/etc/conf.d/reflector.conf
+EnvironmentFile=/usr/share/reflector-timer/reflector.conf
+EnvironmentFile=-/etc/conf.d/reflector.conf
ExecStart=/usr/bin/reflector --age $AGE --country $COUNTRY --latest $LATEST --number $NUMBER --sort $SORT --save /etc/pacman.d/mirrorlist
diff --git a/reflector.timer b/reflector.timer
index bc6b8a639731..0f12fee678e1 100644
--- a/reflector.timer
+++ b/reflector.timer
@@ -5,3 +5,6 @@ Description=Daily pacman mirrorlist refresh
OnCalendar=daily
Persistent=true
AccuracySec=12h
+
+[Install]
+WantedBy=timers.target