summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Berger2016-04-02 11:23:52 +0300
committerAlbert Berger2016-04-02 11:23:52 +0300
commit9539337e038ee0c946c9ef57e88d7f258346dc88 (patch)
treea6250d722120d86747747c9d97e49fa9e7ae7796
parent6c1ada26ecea3227f07419d7c5642a7be2e0b953 (diff)
downloadaur-9539337e038ee0c946c9ef57e88d7f258346dc88.tar.gz
add github submodules
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6039af693988..29392f943500 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Apr 1 21:21:56 UTC 2016
+# Sat Apr 2 08:22:45 UTC 2016
pkgbase = regd-git
pkgdesc = Registry daemon, information cache and secure credential storage.
pkgver = VERSION
@@ -11,6 +11,8 @@ pkgbase = regd-git
provides = regd
conflicts = regd
source = regd::git+https://github.com/nbdsp/regd#branch=master
+ source = git://github.com/nbdsp/appsm.git
+ source = git://github.com/nbdsp/dtlsm.git
md5sums = SKIP
pkgname = regd-git
diff --git a/PKGBUILD b/PKGBUILD
index 316069a8f1e2..0d9d52d899f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,9 @@ replaces=()
backup=()
options=()
install=
-source=("${pkgname%-git}::git+$url#branch=master")
+source=("${pkgname%-git}::git+$url#branch=master"
+ "git://github.com/nbdsp/appsm.git"
+ "git://github.com/nbdsp/dtlsm.git")
noextract=()
md5sums=('SKIP')
@@ -31,6 +33,11 @@ package() {
cd "${pkgname%-git}"
pname="${pkgname%-git}"
_username="$(id | sed -e 's/[^(]*(\([^)]*\)).*/\1/')"
+
+ git submodule init
+ git config submodule.appsm.url $srcdir/regd/appsm
+ git config submodule.dtlsm.url $srcdir/regd/dtlsm
+ git submodule update
python setup.py install --root="$pkgdir/" --optimize=1
install -Dm644 -o $_username "data/conf.${pname}" "$pkgdir/etc/${pname}/conf.${pname}"
install -Dm644 -o $_username "data/${pname}.conf" "$pkgdir/usr/lib/tmpfiles.d/${pname}.conf"