summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2017-02-16 18:39:52 +0100
committeraksr2017-02-16 18:39:52 +0100
commit71f88f2f76b6279542a1f1f55862e4e1de8c8b29 (patch)
tree739b5df8a1900218fa14d2524c641b9c7395b201
downloadaur-71f88f2f76b6279542a1f1f55862e4e1de8c8b29.tar.gz
Start.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD53
-rw-r--r--regoth.install15
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6160560ed5bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Feb 16 17:39:51 UTC 2017
+pkgbase = regoth-git
+ pkgdesc = OpenSource-Reimplementation of the zEngine, used by the game 'Gothic'
+ pkgver = 0.1.409.r563.f1b3195
+ pkgrel = 1
+ url = https://github.com/REGoth-project/REGoth
+ install = regoth.install
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = git
+ makedepends = cmake
+ depends = gcc>=6
+ provides = regoth
+ conflicts = regoth
+ source = regoth-git::git+https://github.com/REGoth-project/REGoth.git
+ md5sums = SKIP
+
+pkgname = regoth-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be4c86f9719d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=regoth-git
+pkgver=0.1.409.r563.f1b3195
+pkgrel=1
+epoch=
+pkgdesc="OpenSource-Reimplementation of the zEngine, used by the game 'Gothic'"
+arch=('i686' 'x86_64')
+url="https://github.com/REGoth-project/REGoth"
+license=('GPLv3')
+categories=()
+groups=()
+depends=('gcc>=6')
+makedepends=('git' 'cmake')
+optdepends=()
+checkdepends=()
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+replaces=()
+backup=()
+options=()
+changelog=
+install="${pkgname%-*}".install
+source=("$pkgname::git+https://github.com/REGoth-project/REGoth.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "%s.r%s.%s" "$(git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^nightly.//')" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ git submodule update --init --recursive
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release ..
+ make -j$(grep -c ^processor /proc/cpuinfo)
+}
+
+package() {
+ cd "$srcdir/$pkgname/build/bin"
+ mkdir -p $pkgdir/usr/{bin,share/${pkgname%-*}/}
+ for i in REGoth altonegen openal-info makehrtf bsincgen; do
+ install -Dm755 $i "$pkgdir/usr/share/${pkgname%-*}/$i"
+ done
+ ln -rs $pkgdir/usr/share/${pkgname%-*}/REGoth $pkgdir/usr/bin/REGoth
+ cp -r shaders $pkgdir/usr/share/${pkgname%-*}/
+ install -Dm644 ../../README.md $pkgdir/usr/share/doc/${pkgname%-*}/README.md
+ install -Dm644 ../../LICENSE.md $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+}
+
diff --git a/regoth.install b/regoth.install
new file mode 100644
index 000000000000..1abf0a3aacbe
--- /dev/null
+++ b/regoth.install
@@ -0,0 +1,15 @@
+post_install(){
+ echo "==> Running"
+ echo " REGoth -g "path/to/gothic1or2" -w startworld.zen"
+ echo " Additionally, for a list of possible commands, run REGoth --help."
+ echo "==> Examples"
+ echo " Gothic 1 - Overworld: REGoth -g "path/to/gothic1" -w world.zen"
+ echo " Gothic 1 - Oldmine: REGoth -g "path/to/gothic1" -w oldmine.zen"
+ echo " Gothic 1 - Freemine: REGoth -g "path/to/gothic1" -w freemine.zen"
+ echo " Gothic 1 - Sleeper temple: REGoth -g "path/to/gothic1" -w orctemple.zen"
+ echo " Gothic 2 - Overworld: REGoth -g "path/to/gothic2" -w newworld.zen"
+ echo " Gothic 2 - Valley of mines: REGoth -g "path/to/gothic2" -w oldworld.zen"
+ echo " Gothic 2 - Addonworld: REGoth -g "path/to/gothic2" -w addonworld.zen"
+ echo " Gothic 2 - Dragonisland: REGoth -g "path/to/gothic2" -w dragonisland.zen"
+}
+