summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdoardo Rosa2019-04-07 10:36:30 +0200
committerEdoardo Rosa2019-04-07 10:36:30 +0200
commit272596675290870b5eff778b0b218e8b7602679e (patch)
treee87cba2a5c7980044fa7e6320ad79a14f2d92110
parentc4f4dcd397ea326911c20093ba5dadd609aa1641 (diff)
downloadaur-272596675290870b5eff778b0b218e8b7602679e.tar.gz
fix installation
-rw-r--r--PKGBUILD4
-rw-r--r--patch.diff26
2 files changed, 15 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ca6a02228de..9aef316426bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# RegRipper
pkgname=regripper-git
-pkgver=r118.79e852a
+pkgver=r163.6aa233a
pkgrel=1
pkgdesc="RegRipper is an open source forensic software used as a Windows Registry data extraction command line or GUI tool."
arch=('any')
@@ -13,7 +13,7 @@ options=('!emptydirs')
source=("$pkgname::git+https://github.com/keydet89/RegRipper2.8.git"
"patch.diff")
md5sums=('SKIP'
- 'a8455a8a0ad1fbf3880c9771db24e36e')
+ 'cd51371361a3377bf6af11ee1630e09e')
pkgver() {
cd "$pkgname"
diff --git a/patch.diff b/patch.diff
index 67af85f4f85b..224a22db96cf 100644
--- a/patch.diff
+++ b/patch.diff
@@ -1,26 +1,26 @@
---- rip.pl 2017-04-10 03:17:50.442178408 +0200
-+++ regripper 2017-04-10 03:17:46.646189632 +0200
-@@ -1,4 +1,5 @@
+diff --git a/rip.pl b/rip.pl
+index ef8815a..265a56c 100644
+--- a/rip.pl
++++ b/rip.pl
+@@ -1,4 +1,4 @@
-#! c:\perl\bin\perl.exe
+#!/usr/bin/perl
-+use lib qw(/usr/local/lib/rip-lib/lib/perl5/);
#-------------------------------------------------------------------------
# Rip - RegRipper, CLI version
# Use this utility to run a plugins file or a single plugin against a Reg
-@@ -60,7 +61,7 @@
- #push(@INC,$str);
-
+@@ -62,7 +62,7 @@ $str =~ s/($path[scalar(@path) - 1])//;
+ # code updated 20190318
+ my $plugindir;
+ ($^O eq "MSWin32") ? ($plugindir = $str."plugins/")
+- : ($plugindir = File::Spec->catfile("plugins"));
++ : ($plugindir = File::Spec->catfile("/usr/share/regripper/plugins"));
#my $plugindir = $str."plugins/";
--my $plugindir = File::Spec->catfile("plugins");
-+my $plugindir = File::Spec->catfile("/usr/share/regripper/plugins");
+ #my $plugindir = File::Spec->catfile("plugins");
#print "Plugins Dir = ".$plugindir."\n";
- # End code update
- my $VERSION = "2\.8_20130801";
-@@ -347,4 +348,5 @@
+@@ -401,4 +401,4 @@ sub getTime($$) {
};
$t = 0 if ($t < 0);
return $t;
-}
\ No newline at end of file
+}
-+