summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2020-10-19 16:22:58 +0300
committerLev Levitsky2020-10-19 16:22:58 +0300
commit34a127def838cd590afcabaf18297fea5dd30119 (patch)
tree8b03af90f3fb8410a220c8657e833d9cdf995214
downloadaur-34a127def838cd590afcabaf18297fea5dd30119.tar.gz
Initial
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD44
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d4f34aa4102
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = regtools-git
+ pkgdesc = Tools that integrate DNA-seq and RNA-seq data to help interpret mutations in a regulatory and splicing context
+ pkgver = 0.6.0.r0.9221a19
+ pkgrel = 1
+ url = https://github.com/griffithlab/regtools
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ provides = regtools
+ conflicts = regtools
+ source = git+https://github.com/griffithlab/regtools.git
+ md5sums = SKIP
+
+pkgname = regtools-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ad2929e5f8a0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.zst
+regtools/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fc10d858d4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Lev Levitsky <levlev<at>mail.ru>
+pkgname=regtools-git
+pkgver=0.6.0.r0.9221a19
+pkgrel=1
+pkgdesc="Tools that integrate DNA-seq and RNA-seq data to help interpret mutations in a regulatory and splicing context"
+arch=('any')
+url="https://github.com/griffithlab/regtools"
+license=('MIT')
+groups=()
+depends=()
+makedepends=('git' 'cmake')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/griffithlab/regtools.git')
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # Git, tags available
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir build
+ cd build
+ cmake ..
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}/build"
+ install -d "$pkgdir/usr/bin"
+ install "${pkgname%-git}" "$pkgdir/usr/bin/"
+}