summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-11-07 16:55:15 -0800
committerxiota2023-11-07 16:55:15 -0800
commit88cec89c323659a7d3393df29b13b2370fdf0717 (patch)
tree2cc6b7df382af467490d19583a1ba789be05e01b
parent3595370c37a2c6e7bdc1f902fdca733670184221 (diff)
downloadaur-reicast-git.tar.gz
metapackage
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 18 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10430ea5f60c..aa212a34354c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,9 @@
pkgbase = reicast-git
- pkgdesc = A multiplatform Sega Dreamcast emulator (development version)
- pkgver = 20.04.r48.g0bd6ea371
+ pkgdesc = metapackage - migrate to flycast-git
+ pkgver = 0.0.1
pkgrel = 1
- url = http://reicast.com/
- arch = i686
- arch = x86_64
- arch = armv7h
- license = custom
- makedepends = git
- depends = libgl
- depends = alsa-lib
- depends = libpulse
- optdepends = python: for joystick configuration utility
- provides = reicast
- conflicts = reicast
- source = reicast::git+https://github.com/reicast/reicast-emulator.git
- md5sums = SKIP
+ epoch = 1
+ arch = any
pkgname = reicast-git
-
+ depends = flycast-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 879e441e097f..a9d7b805b2db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,13 @@
-# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-# Contributor: Holzhaus <jan.holthuis@ruhr-uni-bochum.de>
+# Maintainer:
-pkgname=reicast-git
-pkgver=20.04.r48.g0bd6ea371
+_newpkg='flycast-git'
+pkgname='reicast-git'
+pkgver=0.0.1
pkgrel=1
-pkgdesc="A multiplatform Sega Dreamcast emulator (development version)"
-arch=('i686' 'x86_64' 'armv7h')
-url="http://reicast.com/"
-license=('custom')
-conflicts=('reicast')
-provides=('reicast')
-makedepends=('git')
-depends=('libgl' 'alsa-lib' 'libpulse')
-optdepends=('python: for joystick configuration utility')
-source=(reicast::"git+https://github.com/reicast/reicast-emulator.git")
-md5sums=('SKIP')
+epoch=1
+pkgdesc="metapackage - migrate to $_newpkg"
+arch=('any')
-pkgver() {
- cd reicast
- git describe --long | sed 's/^r//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-build () {
- USE_PULSEAUDIO=1 make -C reicast/reicast/linux PREFIX=/usr
-}
-
-package () {
- cd reicast
- make -C reicast/linux DESTDIR="$pkgdir/" PREFIX=/usr install
- # licenses
- install -d "$pkgdir"/usr/share/licenses/$pkgname
- install -m644 LICENSE* "$pkgdir"/usr/share/licenses/$pkgname/
+package() {
+ depends=("$_newpkg")
}