summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal2015-10-27 19:45:17 +0000
committerMichal2015-10-27 19:45:17 +0000
commiteef9bcc5aad8d9e976d29a8fad29982c5271df6b (patch)
tree53356b755fbfec85d2eceb0a5d45dbd187cad4b6
downloadaur-eef9bcc5aad8d9e976d29a8fad29982c5271df6b.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--relevation-python2.patch46
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99033e8a6747
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = relevation
+ pkgdesc = Command-line search for Revelation Password Manager files
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://p.outlyer.net/relevation/
+ arch = any
+ license = custom
+ makedepends = python2-setuptools
+ depends = python2-crypto
+ depends = python2-lxml
+ source = http://p.outlyer.net/relevation/files/relevation-1.3.tar.gz
+ source = relevation-python2.patch
+ md5sums = 4b5ec6152c7c6a26f4aa3e1f157ef4e3
+ md5sums = a020e1a4f8aeb056f2335224ed3ee3c7
+
+pkgname = relevation
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d39cdea6fcf7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Michal Lisowski <lisu87@gmail.com>
+pkgname=relevation
+pkgver=1.3
+pkgrel=1
+pkgdesc="Command-line search for Revelation Password Manager files"
+arch=('any')
+url="http://p.outlyer.net/relevation/"
+license=('custom')
+depends=('python2-crypto' 'python2-lxml')
+makedepends=('python2-setuptools')
+source=("http://p.outlyer.net/relevation/files/relevation-1.3.tar.gz"
+ "$pkgname-python2.patch")
+md5sums=('4b5ec6152c7c6a26f4aa3e1f157ef4e3'
+ 'a020e1a4f8aeb056f2335224ed3ee3c7')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/$pkgname-python2.patch"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make prefix=/usr DESTDIR="$pkgdir/" install
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/relevation-python2.patch b/relevation-python2.patch
new file mode 100644
index 000000000000..293c4ab4b5ce
--- /dev/null
+++ b/relevation-python2.patch
@@ -0,0 +1,46 @@
+--- relevation-1.3/GNUmakefile.bak 2015-10-23 13:04:23.580801901 +0100
++++ relevation-1.3/GNUmakefile 2015-10-23 13:47:30.214234538 +0100
+@@ -17,8 +17,8 @@
+ INSTALLROOT=$(DESTDIR)$(prefix)
+ MANROOT=$(INSTALLROOT)/share/man
+ # Where to install additional packages
+-PYTHONROOT=$(DESTDIR)$(shell python -c "import sys;from distutils import sysconfig; print sysconfig.get_python_lib(0,0,prefix='$(prefix)')")
+-DUSETUP=python setup.py # Distutils' setup
++PYTHONROOT=$(DESTDIR)$(shell python2 -c "import sys;from distutils import sysconfig; print sysconfig.get_python_lib(0,0,prefix='$(prefix)')")
++DUSETUP=python2 setup.py # Distutils' setup
+ # Debian derived systems need special treatment for clean uninstalls
+ # since it uses different than standard directories
+ INSTALL_LAYOUT=
+@@ -58,7 +58,7 @@
+ @echo INSTALL_LAYOUT=$(INSTALL_LAYOUT)
+
+ test_min_python: pyqver2.py
+- python pyqver2.py -v -m 2.4 src/$(PKG).py src/$(PKG)/*.py
++ python2 pyqver2.py -v -m 2.4 src/$(PKG).py src/$(PKG)/*.py
+
+ install: setup.py
+ $(DUSETUP) install --prefix=$(DESTDIR)$(prefix) $(INSTALL_LAYOUT)
+--- relevation-1.3/src/relevation.py.bak 2015-10-23 13:48:17.049070526 +0100
++++ relevation-1.3/src/relevation.py 2015-10-23 13:49:02.400525749 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # -*- coding: UTF-8 -*-
+
+ """
+--- relevation-1.3/src/relevation/PBKDF2.py.bak 2015-10-23 13:57:27.250307970 +0100
++++ relevation-1.3/src/relevation/PBKDF2.py 2015-10-23 13:57:36.087274759 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+ # -*- coding: ascii -*-
+ ###########################################################################
+ # pbkdf2 - PKCS#5 v2.0 Password-Based Key Derivation
+--- relevation-1.3/src/gui.py.bak 2015-10-23 13:59:00.340134738 +0100
++++ relevation-1.3/src/gui.py 2015-10-23 13:59:11.243838009 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # -*- coding: UTF-8 -*-
+
+ """