summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorayekat2019-06-10 17:54:23 +0200
committerayekat2019-06-10 17:54:23 +0200
commit4b0a4c4ea3b9414c35519f0ca0d7d47419763ee5 (patch)
tree2a7d27b45c2f9734b167f946e6180ac8f03254b6
parentaa687831e7e5de1f3fb5181c9e2b2b93cab56c0c (diff)
downloadaur-4b0a4c4ea3b9414c35519f0ca0d7d47419763ee5.tar.gz
0.8-1
There isn't much new remakepkg-wise (most upstream changes are mostly zr-specific this time).
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
-rw-r--r--changelog6
3 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ab00d538e54..9e8ff5e7f28e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = remakepkg
pkgdesc = Apply changes to pacman packages
- pkgver = 0.7.8
+ pkgver = 0.8
pkgrel = 1
url = https://gitlab.com/ayekat/pacman-hacks
changelog = changelog
@@ -9,16 +9,14 @@ pkgbase = remakepkg
makedepends = asciidoc
makedepends = git
depends = coreutils
- depends = sed
conflicts = makemetapkg
- source = git+https://gitlab.com/ayekat/pacman-hacks.git#tag=v0.7.8
+ source = git+https://gitlab.com/ayekat/pacman-hacks.git#tag=v0.8
source = diffrepo.hook.example
sha256sums = SKIP
sha256sums = 4b723cf33b30f6176f8f50623c2325d05d5dc70463ca2bcd893fae2ccab5776e
pkgname = remakepkg
depends = coreutils
- depends = sed
depends = bash
depends = curl
depends = expac
@@ -27,6 +25,7 @@ pkgname = remakepkg
depends = fakeroot
depends = libarchive
depends = pacman
+ depends = sed
depends = sh
depends = vi
diff --git a/PKGBUILD b/PKGBUILD
index c53a3273de0b..d96363685357 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tinu Weber <http://ayekat.ch>
pkgname=remakepkg
-pkgver=0.7.8
+pkgver=0.8
pkgrel=1
arch=(any)
@@ -14,7 +14,7 @@ license=(GPL3)
# https://gitlab.com/ayekat/PKGBUILDs/tree/pacman-hacks
conflicts=(makemetapkg)
-depends=(coreutils sed)
+depends=(coreutils)
makedepends=(asciidoc git)
changelog='changelog'
@@ -28,12 +28,11 @@ _tools='diffrepo getpkg pkgmirror remakepkg repkg'
build() {
cd pacman-hacks
- make clean
make PREFIX=/usr SCRIPTS="$_tools" MANPAGES="$_tools"
}
package() {
- depends+=(bash curl expac grep gzip fakeroot libarchive pacman sh vi)
+ depends+=(bash curl expac grep gzip fakeroot libarchive pacman sed sh vi)
cd pacman-hacks
make \
diff --git a/changelog b/changelog
index 26879dffbcca..a17bb5f6d9a4 100644
--- a/changelog
+++ b/changelog
@@ -1,3 +1,9 @@
+v0.8-1 (2019-06-10)
+* pkgmirror: Use pacman-conf to obtain package URL
+* Readme: Fix list of dependencies (bugfix)
+* getpkg: Properly fail on 404 (bugfix)
+* More bug fixes as in v0.7.1--v0.7.8
+
v0.7.8-1 (2019-05-13)
* Makefile: Fix target dependencies to allow multithreaded building
* man pages: Clarify/improve some sections