summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2023-10-02 08:58:36 -0400
committerAndrew Sun2023-10-02 08:58:36 -0400
commit12c75d6e8609c413779951b0904233ce643ffc0b (patch)
tree69e68be29ee11fbfe30ae68064fb8fce7b8c3f71
parentcef1ceb0b1a2c7807b0ca4ffbf487e6b99903911 (diff)
downloadaur-12c75d6e8609c413779951b0904233ce643ffc0b.tar.gz
remove unnecessary pandoc conflict, remove files that belong to haskell-yaml package
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5517fa3de9f5..ac68f3ae84fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = remarshal
pkgdesc = Convert between CBOR, JSON, MessagePack, TOML, and YAML
pkgver = 0.17.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/dbohdan/remarshal
arch = any
license = MIT
@@ -15,7 +15,6 @@ pkgbase = remarshal
depends = python-tomlkit
depends = python-u-msgpack
depends = python-yaml
- conflicts = pandoc
options = !emptydirs
source = https://files.pythonhosted.org/packages/source/r/remarshal/remarshal-0.17.1.tar.gz
sha256sums = 826a41d3e3ed9d45422811488d7b28cc146a8d5b2583b18db36302f87091a86d
diff --git a/PKGBUILD b/PKGBUILD
index 598f19060e24..4e7815803679 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=remarshal
pkgver=0.17.1
-pkgrel=2
+pkgrel=3
pkgdesc='Convert between CBOR, JSON, MessagePack, TOML, and YAML'
arch=(any)
url="https://github.com/dbohdan/$pkgname"
@@ -17,7 +17,6 @@ _pydeps=(cbor2
depends=(python
"${_pydeps[@]/#/python-}")
makedepends=(python-build python-installer python-wheel python-poetry-core)
-conflicts=(pandoc)
options=('!emptydirs')
_archive="$pkgname-$pkgver"
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$_archive.tar.gz")
@@ -37,4 +36,7 @@ package() {
cd "$_archive"
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+
+ # remove files owned by haskell-yaml to prevent conflicts
+ rm "$pkgdir/usr/bin/json2yaml" "$pkgdir/usr/bin/yaml2json"
}