summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-09-03 11:43:31 -0700
committerAndy Weidenbaum2016-09-03 11:43:31 -0700
commit8558f1774038bebbb9057050ab9e5f39172aa2b3 (patch)
treebc1716ed98b37b7308ee31840a047e0fd49b1bc1
parentbc264dfa473c78f0841d21081f39781ed15c96f7 (diff)
downloadaur-8558f1774038bebbb9057050ab9e5f39172aa2b3.tar.gz
update pkgver to 0.6.0, go -> python
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 27 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a5fcf0bd0fb..003529ee34df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Sep 3 18:42:53 UTC 2016
pkgbase = remarshal
pkgdesc = Convert between TOML, YAML and JSON
- pkgver = 0.3.0
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/dbohdan/remarshal
- arch = i686
- arch = x86_64
+ arch = any
license = MIT
- makedepends = git
- makedepends = go
- options = !strip
+ makedepends = python-setuptools
+ depends = python
+ depends = python-dateutil
+ depends = python-pytoml
+ depends = python-yaml
options = !emptydirs
- source = remarshal-0.3.0.tar.gz::https://codeload.github.com/dbohdan/remarshal/tar.gz/v0.3.0
- sha256sums = b011d955bac62253dbfdb79abfa37b0a1f175618f2707ebbd0337532672ce683
+ source = remarshal-0.6.0.tar.gz::https://codeload.github.com/dbohdan/remarshal/tar.gz/v0.6.0
+ sha256sums = 19e85b010ada81f3094ce4e607d6f26aeb2ea40c92c4c704fe1cdb8fd8f637ee
pkgname = remarshal
diff --git a/PKGBUILD b/PKGBUILD
index de97c8a81a51..87e4f03463da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,34 @@
# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
pkgname=remarshal
-pkgver=0.3.0
+pkgver=0.6.0
pkgrel=1
pkgdesc="Convert between TOML, YAML and JSON"
-arch=('i686' 'x86_64')
-makedepends=('git' 'go')
+arch=('any')
+depends=('python' 'python-dateutil' 'python-pytoml' 'python-yaml')
+makedepends=('python-setuptools')
url="https://github.com/dbohdan/remarshal"
license=('MIT')
-options=('!strip' '!emptydirs')
+options=('!emptydirs')
source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/dbohdan/$pkgname/tar.gz/v$pkgver)
-sha256sums=('b011d955bac62253dbfdb79abfa37b0a1f175618f2707ebbd0337532672ce683')
-
-prepare() {
- msg 'Fetching toml go bindings...'
- GOPATH="$srcdir" go get -d github.com/BurntSushi/toml
-
- msg 'Fetching yaml go bindings...'
- GOPATH="$srcdir" go get -d gopkg.in/yaml.v2
-}
+sha256sums=('19e85b010ada81f3094ce4e607d6f26aeb2ea40c92c4c704fe1cdb8fd8f637ee')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/${pkgname#python-}-$pkgver"
- msg 'Building...'
- GOPATH="$srcdir" go build remarshal.go
+ msg2 'Building...'
+ python setup.py build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- msg 'Installing license...'
- install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir/${pkgname#python-}-$pkgver"
- msg 'Installing documentation...'
- install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
- msg 'Installing...'
- install -Dm 755 remarshal "$pkgdir/usr/bin/remarshal"
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
- msg 'Cleaning up pkgdir...'
- find "$pkgdir" -type d -name .git -exec rm -r '{}' +
- find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+ msg2 'Installing...'
+ python setup.py install --root="$pkgdir" --optimize=1
}