summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-07-20 19:37:13 -0400
committerAndrew Sun2019-07-20 19:37:13 -0400
commit96b868a36cd28df1a4c0088506288bbae34a8afc (patch)
tree66c3d4390c32fd2347bf202c50a09431afc99880
parent5f20dd10931b2005997dfccc7743cea56ad2219d (diff)
downloadaur-96b868a36cd28df1a4c0088506288bbae34a8afc.tar.gz
remarshal: update to 0.11.2
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
2 files changed, 16 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 275f8e9b180f..346daa9e7c71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
-# Generated by mksrcinfo v8
-# Wed Jul 12 19:46:58 UTC 2017
pkgbase = remarshal
pkgdesc = Convert between TOML, YAML and JSON
- pkgver = 0.7.0
+ pkgver = 0.11.2
pkgrel = 1
url = https://github.com/dbohdan/remarshal
arch = any
license = MIT
makedepends = python-setuptools
- depends = python
depends = python-dateutil
depends = python-pytoml
depends = python-yaml
- conflicts = haskell-yaml
+ depends = python-u-msgpack
options = !emptydirs
- source = remarshal-0.7.0.tar.gz::https://codeload.github.com/dbohdan/remarshal/tar.gz/v0.7.0
- sha256sums = 785f1928e3522671a21eb2e0ce7b6882e8589ccb195b4ee49dec2403fe3d6f4b
+ source = remarshal-0.11.2.tar.gz::https://github.com/dbohdan/remarshal/archive/v0.11.2.tar.gz
+ sha256sums = 3f383e48f59722a4d93ef2b5e417b6a8c152f382a1faad416099ffcde5c87a66
pkgname = remarshal
diff --git a/PKGBUILD b/PKGBUILD
index 953663392987..a94fe28816ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,28 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=remarshal
-pkgver=0.7.0
+pkgver=0.11.2
pkgrel=1
pkgdesc="Convert between TOML, YAML and JSON"
arch=('any')
-depends=('python' 'python-dateutil' 'python-pytoml' 'python-yaml')
-makedepends=('python-setuptools')
url="https://github.com/dbohdan/remarshal"
license=('MIT')
+depends=('python-dateutil' 'python-pytoml' 'python-yaml' 'python-u-msgpack')
+makedepends=('python-setuptools')
options=('!emptydirs')
-source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/dbohdan/$pkgname/tar.gz/v$pkgver)
-sha256sums=('785f1928e3522671a21eb2e0ce7b6882e8589ccb195b4ee49dec2403fe3d6f4b')
-conflicts=('haskell-yaml')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/dbohdan/remarshal/archive/v${pkgver}.tar.gz")
+sha256sums=('3f383e48f59722a4d93ef2b5e417b6a8c152f382a1faad416099ffcde5c87a66')
build() {
- cd "$srcdir/${pkgname#python-}-$pkgver"
-
- msg2 'Building...'
+ cd "${srcdir}/${pkgname#python-}-${pkgver}"
python setup.py build
}
package() {
- cd "$srcdir/${pkgname#python-}-$pkgver"
-
- msg2 'Installing license...'
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
-
- msg2 'Installing documentation...'
- install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ cd "${srcdir}/${pkgname#python-}-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
- msg2 'Installing...'
- python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}