summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2023-07-30 13:23:00 -0400
committerAndrew Sun2023-07-30 13:23:00 -0400
commitb4466a4c610d3e031118d64083077936c864b15d (patch)
tree1889797df777becbcc1f06704d167aaae3c27fe1
parent7a9464240ac73fafa29dbfc61f278f87fe409f62 (diff)
downloadaur-b4466a4c610d3e031118d64083077936c864b15d.tar.gz
fix build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2079442a9e47..cac17cec4b20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,10 @@ pkgbase = remarshal
url = https://github.com/dbohdan/remarshal
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-poetry-core
depends = python
depends = python-cbor2
depends = python-dateutil
diff --git a/PKGBUILD b/PKGBUILD
index 8f24a2792dd7..5fdaa148959b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,19 +16,24 @@ _pydeps=(cbor2
yaml)
depends=(python
"${_pydeps[@]/#/python-}")
-makedepends=(python-setuptools)
+makedepends=(python-build python-installer python-wheel python-poetry-core)
options=('!emptydirs')
_archive="$pkgname-$pkgver"
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$_archive.tar.gz")
sha256sums=('1cb2d4de31763bbac175f0e493e195568f956318caa70ac3359ff794932628cf')
+prepare() {
+ cd "$_archive"
+ rm -rf dist/
+}
+
build() {
- cd "$_archive"
- python setup.py build
+ cd "$_archive"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+ cd "$_archive"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
}