summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commitbc264dfa473c78f0841d21081f39781ed15c96f7 (patch)
tree3069b293107baa6a8eb700ce563396769f49a2a8
downloadaur-bc264dfa473c78f0841d21081f39781ed15c96f7.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a5fcf0bd0fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = remarshal
+ pkgdesc = Convert between TOML, YAML and JSON
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/dbohdan/remarshal
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ options = !strip
+ options = !emptydirs
+ source = remarshal-0.3.0.tar.gz::https://codeload.github.com/dbohdan/remarshal/tar.gz/v0.3.0
+ sha256sums = b011d955bac62253dbfdb79abfa37b0a1f175618f2707ebbd0337532672ce683
+
+pkgname = remarshal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de97c8a81a51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=remarshal
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Convert between TOML, YAML and JSON"
+arch=('i686' 'x86_64')
+makedepends=('git' 'go')
+url="https://github.com/dbohdan/remarshal"
+license=('MIT')
+options=('!strip' '!emptydirs')
+source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/dbohdan/$pkgname/tar.gz/v$pkgver)
+sha256sums=('b011d955bac62253dbfdb79abfa37b0a1f175618f2707ebbd0337532672ce683')
+
+prepare() {
+ msg 'Fetching toml go bindings...'
+ GOPATH="$srcdir" go get -d github.com/BurntSushi/toml
+
+ msg 'Fetching yaml go bindings...'
+ GOPATH="$srcdir" go get -d gopkg.in/yaml.v2
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg 'Building...'
+ GOPATH="$srcdir" go build remarshal.go
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg 'Installing license...'
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ msg 'Installing documentation...'
+ install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+
+ msg 'Installing...'
+ install -Dm 755 remarshal "$pkgdir/usr/bin/remarshal"
+
+ msg 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+ find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+}