summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2022-02-13 19:38:40 -0600
committerkyechou2022-02-13 19:38:40 -0600
commitc2eb1efa0584361147528f23e1d2014bddf74ad0 (patch)
tree393f44a00fe66a2dbd7f5fb8cdfe0140cd68f91f
parent09e4cd81170aab8843ce7e9bbff67431bc042bc7 (diff)
downloadaur-remill-git.tar.gz
Update to 4.2.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1d90dac391f..a88fac3674e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = remill-git
pkgdesc = Library for lifting of x86, amd64, and aarch64 machine code to LLVM bitcode
- pkgver = 4.0.24.r18.gd8d3b6c7
+ pkgver = 4.2.0.r6.g161e0358
pkgrel = 1
url = https://github.com/lifting-bits/remill
arch = x86_64
license = Apache
makedepends = cmake
makedepends = ninja
- depends = cxx-common=0.1.4
+ depends = cxx-common=0.1.8
depends = lib32-glibc
depends = lib32-gcc-libs
depends = libunwind
diff --git a/PKGBUILD b/PKGBUILD
index 6a7ca4231a61..77b00d40588e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Maintainer: Kuan-Yen Chou <kuanyenchou at gmail dot com>
pkgname=remill-git
-pkgver=4.0.24.r18.gd8d3b6c7
+pkgver=4.2.0.r6.g161e0358
pkgrel=1
pkgdesc="Library for lifting of x86, amd64, and aarch64 machine code to LLVM bitcode"
arch=('x86_64')
url="https://github.com/lifting-bits/remill"
license=('Apache')
-depends=('cxx-common=0.1.4' 'lib32-glibc' 'lib32-gcc-libs' 'libunwind')
+depends=('cxx-common=0.1.8' 'lib32-glibc' 'lib32-gcc-libs' 'libunwind')
makedepends=('cmake' 'ninja')
checkdepends=()
provides=('remill')
@@ -51,7 +51,7 @@ package() {
cd "$srcdir/$pkgname/build"
DESTDIR="${pkgdir}" cmake --build . --target install
sed -i "$pkgdir/usr/lib/cmake/remill/remillTargets.cmake" \
- -e "s|$srcdir/$pkgname/build/lib|/usr/include/remill|g"
+ -e "s,$srcdir/$pkgname/build/lib,/usr/include/remill,g"
}
# vim: set sw=4 ts=4 et: