summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2020-12-24 12:11:40 -0600
committerkyechou2020-12-24 12:11:43 -0600
commitb0d9189a00d19e5a92cfe47bb44e49499da4e6f5 (patch)
treef18433ed8d00470a71b061a1c2a013d97ab769bc
parent5ae7e9eabfe9460166617a96633a03e14b8ec8e6 (diff)
downloadaur-b0d9189a00d19e5a92cfe47bb44e49499da4e6f5.tar.gz
Update to 4.0.11
-rw-r--r--.SRCINFO10
-rw-r--r--00-fix-CONVERT-instructions.patch27
-rw-r--r--01-show-instruction.patch66
-rw-r--r--PKGBUILD24
4 files changed, 12 insertions, 115 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0be4bfda6836..24d3289077a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = remill-git
pkgdesc = Library for lifting of x86, amd64, and aarch64 machine code to LLVM bitcode
- pkgver = v4.0.9.r0.gbf69d9ca
- pkgrel = 2
+ pkgver = 4.0.11.r0.g37741957
+ pkgrel = 1
url = https://github.com/lifting-bits/remill
arch = x86_64
license = Apache
@@ -14,12 +14,8 @@ pkgbase = remill-git
depends = libunwind
provides = remill
conflicts = remill
- source = remill-git::git+https://github.com/lifting-bits/remill.git
- source = 00-fix-CONVERT-instructions.patch
- source = 01-show-instruction.patch
+ source = remill-git::git+https://github.com/lifting-bits/remill
sha256sums = SKIP
- sha256sums = b2ab3e9c6b047eddac5cffb189b260fa0c1f6e21c88b343fcaef79110544f9e6
- sha256sums = 16009715ef4e2546349238120ab9ad0c04ef1ed77cc360e64f599aeb4a0ad987
pkgname = remill-git
diff --git a/00-fix-CONVERT-instructions.patch b/00-fix-CONVERT-instructions.patch
deleted file mode 100644
index 67b67f6af88e..000000000000
--- a/00-fix-CONVERT-instructions.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/lib/Arch/X86/Semantics/CONVERT.cpp
-+++ b/lib/Arch/X86/Semantics/CONVERT.cpp
-@@ -333,18 +333,18 @@
-
- namespace {
- template <typename S2>
--DEF_SEM(CVTSI2SS, V128W dst_src1, S2 src2) {
-- auto src1_vec = FReadV32(dst_src1);
-+DEF_SEM(CVTSI2SS, V128W dst, V128 src1, S2 src2) {
-+ auto src1_vec = FReadV32(src1);
- auto conv_val = Float32(Signed(Read(src2)));
-- FWriteV32(dst_src1, FInsertV32(src1_vec, 0, conv_val));
-+ FWriteV32(dst, FInsertV32(src1_vec, 0, conv_val));
- return memory;
- }
-
- template <typename S2>
--DEF_SEM(CVTSI2SD, V128W dst_src1, S2 src2) {
-- auto src1_vec = FReadV64(dst_src1);
-+DEF_SEM(CVTSI2SD, V128W dst, V128 src1, S2 src2) {
-+ auto src1_vec = FReadV64(src1);
- auto conv_val = Float64(Signed(Read(src2)));
-- FWriteV64(dst_src1, FInsertV64(src1_vec, 0, conv_val));
-+ FWriteV64(dst, FInsertV64(src1_vec, 0, conv_val));
- return memory;
- }
-
diff --git a/01-show-instruction.patch b/01-show-instruction.patch
deleted file mode 100644
index 8a8e8098268c..000000000000
--- a/01-show-instruction.patch
+++ /dev/null
@@ -1,66 +0,0 @@
---- a/lib/BC/InstructionLifter.cpp
-+++ b/lib/BC/InstructionLifter.cpp
-@@ -538,7 +538,8 @@
- } else {
- CHECK(arg_type->isIntegerTy() || arg_type->isFloatingPointTy())
- << "Expected " << arch_reg.name << " to be an integral or float type "
-- << "for instruction at " << std::hex << inst.pc;
-+ << "for instruction at " << std::hex << inst.pc << std::endl
-+ << "inst.Serialize(): " << inst.Serialize();
-
- auto val = LoadRegValue(block, state_ptr, arch_reg.name);
-
-@@ -552,12 +553,14 @@
- if (arg_type->isIntegerTy()) {
- CHECK(val_type->isIntegerTy())
- << "Expected " << arch_reg.name << " to be an integral type "
-- << "for instruction at " << std::hex << inst.pc;
-+ << "for instruction at " << std::hex << inst.pc << std::endl
-+ << "inst.Serialize(): " << inst.Serialize();
-
- CHECK(word_size == arg_size)
- << "Expected integer argument to be machine word size ("
- << word_size << " bits) but is is " << arg_size << " instead "
-- << "in instruction at " << std::hex << inst.pc;
-+ << "in instruction at " << std::hex << inst.pc << std::endl
-+ << "inst.Serialize(): " << inst.Serialize();
-
- val = new llvm::ZExtInst(val, impl->word_type,
- llvm::Twine::createNull(), block);
-@@ -565,7 +568,8 @@
- } else if (arg_type->isFloatingPointTy()) {
- CHECK(val_type->isFloatingPointTy())
- << "Expected " << arch_reg.name << " to be a floating point type "
-- << "for instruction at " << std::hex << inst.pc;
-+ << "for instruction at " << std::hex << inst.pc << std::endl
-+ << "inst.Serialize(): " << inst.Serialize();
-
- val = new llvm::FPExtInst(val, arg_type, llvm::Twine::createNull(),
- block);
-@@ -575,12 +579,14 @@
- if (arg_type->isIntegerTy()) {
- CHECK(val_type->isIntegerTy())
- << "Expected " << arch_reg.name << " to be an integral type "
-- << "for instruction at " << std::hex << inst.pc;
-+ << "for instruction at " << std::hex << inst.pc << std::endl
-+ << "inst.Serialize(): " << inst.Serialize();
-
- CHECK(word_size == arg_size)
- << "Expected integer argument to be machine word size ("
- << word_size << " bits) but is is " << arg_size << " instead "
-- << "in instruction at " << std::hex << inst.pc;
-+ << "in instruction at " << std::hex << inst.pc << std::endl
-+ << "inst.Serialize(): " << inst.Serialize();
-
- val = new llvm::TruncInst(val, arg_type, llvm::Twine::createNull(),
- block);
-@@ -588,7 +594,8 @@
- } else if (arg_type->isFloatingPointTy()) {
- CHECK(val_type->isFloatingPointTy())
- << "Expected " << arch_reg.name << " to be a floating point type "
-- << "for instruction at " << std::hex << inst.pc;
-+ << "for instruction at " << std::hex << inst.pc << std::endl
-+ << "inst.Serialize(): " << inst.Serialize();
-
- val = new llvm::FPTruncInst(val, arg_type, llvm::Twine::createNull(),
- block);
diff --git a/PKGBUILD b/PKGBUILD
index a513d3e856c1..cdcedda7e09e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Kuan-Yen Chou <kuanyenchou at gmail dot com>
pkgname=remill-git
-pkgver=v4.0.9.r0.gbf69d9ca
-pkgrel=2
+pkgver=4.0.11.r0.g37741957
+pkgrel=1
pkgdesc="Library for lifting of x86, amd64, and aarch64 machine code to LLVM bitcode"
arch=('x86_64')
url="https://github.com/lifting-bits/remill"
@@ -14,22 +14,16 @@ makedepends=('git')
checkdepends=()
provides=('remill')
conflicts=('remill')
-source=("$pkgname::git+https://github.com/lifting-bits/remill.git"
- '00-fix-CONVERT-instructions.patch'
- '01-show-instruction.patch')
-sha256sums=('SKIP'
- 'b2ab3e9c6b047eddac5cffb189b260fa0c1f6e21c88b343fcaef79110544f9e6'
- '16009715ef4e2546349238120ab9ad0c04ef1ed77cc360e64f599aeb4a0ad987')
-
-prepare() {
- cd "$srcdir/$pkgname"
- patch -Np1 -i "$srcdir/00-fix-CONVERT-instructions.patch"
- patch -Np1 -i "$srcdir/01-show-instruction.patch"
-}
+source=("$pkgname::git+https://github.com/lifting-bits/remill")
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ if git describe --long --tags >/dev/null 2>&1; then
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ else
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git describe --always)"
+ fi
}
build() {