summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2020-11-14 16:00:11 -0600
committerkyechou2020-11-14 16:00:11 -0600
commitc668209a69d2e67bc35a3adf851a369c5d2e4181 (patch)
treedceca54388d0346054389bfc6ff4458b9deddcfb
parent7ddcc778c43a80634b531869fd2715a8319e49e1 (diff)
downloadaur-c668209a69d2e67bc35a3adf851a369c5d2e4181.tar.gz
Use cxx-common
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 027bbf94bd31..edff344d8ed6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = remill-git
pkgdesc = Library for lifting of x86, amd64, and aarch64 machine code to LLVM bitcode
pkgver = v4.0.8.r0.g71c4d067
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/lifting-bits/remill
arch = x86_64
license = Apache
makedepends = git
+ depends = cxx-common=0.0.14
depends = ncurses
depends = zlib
depends = lib32-glibc
+ depends = lib32-gcc-libs
provides = remill
conflicts = remill
source = remill-git::git+https://github.com/lifting-bits/remill.git
- source = https://github.com/trailofbits/cxx-common/releases/download/v0.0.14/libraries-llvm1100-ubuntu20.04-amd64.tar.xz
sha256sums = SKIP
- sha256sums = 7a680ea1185dfb83bc8a2c3bdb7930e5c1dfc7d78e3af16da65ca525e82ade39
pkgname = remill-git
diff --git a/PKGBUILD b/PKGBUILD
index 93c84e566e27..5b795d2d9afc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,18 @@
pkgname=remill-git
pkgver=v4.0.8.r0.g71c4d067
-pkgrel=1
-_cxxcommonver=0.0.14
+pkgrel=2
pkgdesc="Library for lifting of x86, amd64, and aarch64 machine code to LLVM bitcode"
arch=('x86_64')
url="https://github.com/lifting-bits/remill"
license=('Apache')
-depends=('ncurses' 'zlib' 'lib32-glibc')
+depends=('cxx-common=0.0.14' 'ncurses' 'zlib' 'lib32-glibc' 'lib32-gcc-libs')
makedepends=('git')
checkdepends=()
provides=('remill')
conflicts=('remill')
-source=("$pkgname::git+https://github.com/lifting-bits/remill.git"
- "https://github.com/trailofbits/cxx-common/releases/download/v${_cxxcommonver}/libraries-llvm1100-ubuntu20.04-amd64.tar.xz")
-sha256sums=('SKIP'
- '7a680ea1185dfb83bc8a2c3bdb7930e5c1dfc7d78e3af16da65ca525e82ade39')
+source=("$pkgname::git+https://github.com/lifting-bits/remill.git")
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
@@ -25,7 +22,7 @@ pkgver() {
}
build() {
- export TRAILOFBITS_LIBRARIES="$srcdir/libraries"
+ export TRAILOFBITS_LIBRARIES="/opt/cxx-common/libraries"
export PATH="${TRAILOFBITS_LIBRARIES}/cmake/bin:${TRAILOFBITS_LIBRARIES}/llvm/bin:${PATH}"
cd "$srcdir/$pkgname"
@@ -42,7 +39,7 @@ build() {
}
check() {
- export TRAILOFBITS_LIBRARIES="$srcdir/libraries"
+ export TRAILOFBITS_LIBRARIES="/opt/cxx-common/libraries"
export PATH="${TRAILOFBITS_LIBRARIES}/cmake/bin:${TRAILOFBITS_LIBRARIES}/llvm/bin:${PATH}"
cd "$srcdir/$pkgname/build"
@@ -53,6 +50,8 @@ check() {
package() {
cd "$srcdir/$pkgname/build"
make DESTDIR="${pkgdir}" install
+ sed -i "$pkgdir/usr/lib/cmake/remill/remillConfig.cmake" \
+ -e "s|$srcdir/$pkgname-$pkgver/build/lib|/usr/include/remill|g"
}
# vim: set sw=4 ts=4 et: