summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-09-21 02:10:23 +0300
committerDimitris Kiziridis2020-09-21 02:10:23 +0300
commit164979ad3719935e9b31e8d467842b044dba5b51 (patch)
treea7f7d457dbbf0f5c35c5a7812b8aac28a43862f5
downloadaur-164979ad3719935e9b31e8d467842b044dba5b51.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27ecaa4f1fa1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = reminduck
+ pkgdesc = A simple reminder app made for elementaryOS with Vala and GTK
+ pkgver = 1.5.6
+ pkgrel = 1
+ url = https://github.com/matfantinel/reminduck
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = ninja
+ makedepends = libgee
+ makedepends = granite
+ makedepends = meson
+ makedepends = vala
+ depends = granite
+ source = reminduck-1.5.6.tar.gz::https://github.com/matfantinel/reminduck/archive/v1.5.6.tar.gz
+ sha256sums = 415863efa03427a25b5dccc42018b6f2318a6ba764ada2c0df9741bc8a088145
+
+pkgname = reminduck
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4741bc122b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=reminduck
+pkgver=1.5.6
+pkgrel=1
+pkgdesc='A simple reminder app made for elementaryOS with Vala and GTK'
+arch=('i686' 'x86_64')
+url='https://github.com/matfantinel/reminduck'
+license=('GPL3')
+depends=('granite')
+makedepends=('ninja'
+ 'libgee'
+ 'granite'
+ 'meson'
+ 'vala')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/matfantinel/reminduck/archive/v${pkgver}.tar.gz")
+sha256sums=('415863efa03427a25b5dccc42018b6f2318a6ba764ada2c0df9741bc8a088145')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ meson . build --prefix=/usr
+ ninja -C build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C build install
+}
+# vim:set ts=2 sw=2 et: