summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Eriksson2023-11-30 17:57:02 +0100
committerMikael Eriksson2023-11-30 17:57:02 +0100
commitf906db8cbe2d8a99cb71ea9954e6ec3520e506cd (patch)
treeac44d3f821a2879ff27ed8ae4e3a318880d4b6bc
parentaab912aa0c93e10224ad866edc11963d85eb1b87 (diff)
downloadaur-reminiscence.tar.gz
0.5.1-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5647210eb3da..57e6b036dc28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = reminiscence
pkgdesc = A rewrite of the flashback engine
- pkgver = 0.4.8
+ pkgver = 0.5.1
pkgrel = 1
url = http://cyxdown.free.fr/reminiscence/
arch = i686
@@ -11,13 +11,14 @@ pkgbase = reminiscence
depends = libmodplug
depends = zlib
depends = bash
- depends = libtremor-git
noextract = flashback_data_files.7z
- source = http://cyxdown.free.fr/reminiscence/REminiscence-0.4.8.tar.bz2
+ source = http://cyxdown.free.fr/reminiscence/REminiscence-0.5.1.tar.bz2
source = http://gtamp.com/PSP/flashback_data_files.7z
+ source = https://github.com/nothings/stb/raw/master/stb_vorbis.c
source = reminiscence.sh
- md5sums = 4297fb6e94297f70e5bdf4e5596abb48
+ md5sums = ca480fdaf4cee5fb61d1b20ace1fa0f6
md5sums = f994412ad4246c587896dab7d2eb9627
+ md5sums = 36713ac98e445271e29547cc2d90b01f
md5sums = 4ed0350e4b81e9ba305f90e157c75371
pkgname = reminiscence
diff --git a/PKGBUILD b/PKGBUILD
index 4affdff233da..b9b22da9e27c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,28 @@
# flashback_data_files.7z if from http://gtamp.com/PSP/reminiscencepsp.php
pkgname=reminiscence
-pkgver=0.4.8
+pkgver=0.5.1
pkgrel=1
pkgdesc="A rewrite of the flashback engine"
arch=('i686' 'x86_64')
url="http://cyxdown.free.fr/reminiscence/"
license=('GPL')
-depends=('sdl2' 'libmodplug' 'zlib' 'bash' 'libtremor-git')
+depends=('sdl2' 'libmodplug' 'zlib' 'bash')
makedepends=('p7zip')
source=(http://cyxdown.free.fr/reminiscence/REminiscence-${pkgver}.tar.bz2
http://gtamp.com/PSP/flashback_data_files.7z
+ https://github.com/nothings/stb/raw/master/stb_vorbis.c
reminiscence.sh)
-md5sums=('4297fb6e94297f70e5bdf4e5596abb48'
+md5sums=('ca480fdaf4cee5fb61d1b20ace1fa0f6'
'f994412ad4246c587896dab7d2eb9627'
+ '36713ac98e445271e29547cc2d90b01f'
'4ed0350e4b81e9ba305f90e157c75371')
noextract=('flashback_data_files.7z')
build() {
- cd "$srcdir/REminiscence-$pkgver"
+ cd "$srcdir/REminiscence-$pkgver"
+ cp "$srcdir/stb_vorbis.c" .
-#make CXX=g++ CXXFLAGS="-Wall -MMD \$(SDL_CFLAGS) -DUSE_MODPLUG -DUSE_ZLIB -O"
make
}