summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Eriksson2020-02-02 21:19:29 +0100
committerMikael Eriksson2020-02-02 21:19:29 +0100
commit7bfb12401e29d5e7e2766a18b93df46b8c69099f (patch)
tree3ef5cfb474f68eeab852239a15bf42cec4dfd0be
parentb275ef35d69989fa81caf0fbae4abbf4d1138bc6 (diff)
downloadaur-7bfb12401e29d5e7e2766a18b93df46b8c69099f.tar.gz
0.4.6-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
-rw-r--r--fix-makefile.patch21
3 files changed, 10 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c695eb45b96..59e78ef149af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,24 @@
pkgbase = reminiscence
pkgdesc = A rewrite of the flashback engine
- pkgver = 0.4.5
+ pkgver = 0.4.6
pkgrel = 1
url = http://cyxdown.free.fr/reminiscence/
arch = i686
arch = x86_64
license = GPL
makedepends = p7zip
- makedepends = patch
depends = sdl2
depends = libmodplug
depends = zlib
depends = bash
depends = libtremor-svn
noextract = flashback_data_files.7z
- source = http://cyxdown.free.fr/reminiscence/REminiscence-0.4.5.tar.bz2
+ source = http://cyxdown.free.fr/reminiscence/REminiscence-0.4.6.tar.bz2
source = http://gtamp.com/PSP/flashback_data_files.7z
source = reminiscence.sh
- source = fix-makefile.patch
- md5sums = ebdb0027c77fceae39b4edfb1b231adc
+ md5sums = 959af798014751c86c69a85f28d54c15
md5sums = f994412ad4246c587896dab7d2eb9627
md5sums = 4ed0350e4b81e9ba305f90e157c75371
- md5sums = 4e0815ccd056c38ab694ca77c03fac51
pkgname = reminiscence
diff --git a/PKGBUILD b/PKGBUILD
index 4652e71cdd80..c4edf94a868c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,27 @@
# flashback_data_files.7z if from http://gtamp.com/PSP/reminiscencepsp.php
pkgname=reminiscence
-pkgver=0.4.5
+pkgver=0.4.6
pkgrel=1
pkgdesc="A rewrite of the flashback engine"
arch=('i686' 'x86_64')
url="http://cyxdown.free.fr/reminiscence/"
license=('GPL')
depends=('sdl2' 'libmodplug' 'zlib' 'bash' 'libtremor-svn')
-makedepends=('p7zip' 'patch')
+makedepends=('p7zip')
source=(http://cyxdown.free.fr/reminiscence/REminiscence-${pkgver}.tar.bz2
http://gtamp.com/PSP/flashback_data_files.7z
- reminiscence.sh
- fix-makefile.patch)
-md5sums=('ebdb0027c77fceae39b4edfb1b231adc'
+ reminiscence.sh)
+md5sums=('959af798014751c86c69a85f28d54c15'
'f994412ad4246c587896dab7d2eb9627'
- '4ed0350e4b81e9ba305f90e157c75371'
- '4e0815ccd056c38ab694ca77c03fac51')
+ '4ed0350e4b81e9ba305f90e157c75371')
noextract=('flashback_data_files.7z')
build() {
cd "$srcdir/REminiscence-$pkgver"
- patch -p1 -i $srcdir/fix-makefile.patch
-
- make CXX=g++ CXXFLAGS="-Wall -MMD \$(SDL_CFLAGS) -DUSE_MODPLUG -DUSE_ZLIB -O"
+#make CXX=g++ CXXFLAGS="-Wall -MMD \$(SDL_CFLAGS) -DUSE_MODPLUG -DUSE_ZLIB -O"
+ make
}
package() {
diff --git a/fix-makefile.patch b/fix-makefile.patch
deleted file mode 100644
index f5c8fce8c25e..000000000000
--- a/fix-makefile.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Index: REminiscence-0.4.5/Makefile
-===================================================================
---- REminiscence-0.4.5.orig/Makefile
-+++ REminiscence-0.4.5/Makefile
-@@ -7,14 +7,14 @@ MODPLUG_LIBS := -lmodplug
- TREMOR_LIBS := -lvorbisidec -logg
- ZLIB_LIBS := -lz
-
--CXXFLAGS += -Wall -Wpedantic -MMD $(SDL_CFLAGS) -DUSE_MODPLUG -DUSE_STATIC_SCALER -DUSE_TREMOR -DUSE_ZLIB
-+CXXFLAGS += -Wall -Wpedantic -MMD $(SDL_CFLAGS) -DUSE_MODPLUG -DUSE_TREMOR -DUSE_ZLIB
-
- SRCS = collision.cpp cpc_player.cpp cutscene.cpp decode_mac.cpp dynlib.cpp file.cpp fs.cpp game.cpp graphics.cpp main.cpp \
- menu.cpp mixer.cpp mod_player.cpp ogg_player.cpp piege.cpp protection.cpp resource.cpp resource_aba.cpp \
- resource_mac.cpp scaler.cpp screenshot.cpp seq_player.cpp \
- sfx_player.cpp staticres.cpp systemstub_sdl.cpp unpack.cpp util.cpp video.cpp
-
--SCALERS := scalers/scaler_nearest.cpp scalers/scaler_tv2x.cpp scalers/scaler_xbr.cpp
-+SCALERS :=
-
- OBJS = $(SRCS:.cpp=.o) $(SCALERS:.cpp=.o)
- DEPS = $(SRCS:.cpp=.d) $(SCALERS:.cpp=.d)