summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:23 +0200
committerMuflone2015-06-13 17:59:23 +0200
commit7b66cdb5493aec0268298fdf5ff2db5505964238 (patch)
tree47f136f2ca92f3e62f0565c1823de2b7a6765a34
downloadaur-7b66cdb5493aec0268298fdf5ff2db5505964238.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
-rw-r--r--remmina-plugin-exec.install11
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..121cd9d40ba0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = remmina-plugin-exec
+ pkgdesc = A protocol plugin for Remmina to execute an external process.
+ pkgver = 1.1.1.0
+ pkgrel = 2
+ url = http://www.muflone.com/remmina-plugin-exec/
+ install = remmina-plugin-exec.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkg-config
+ makedepends = cmake
+ depends = gtk3
+ depends = remmina
+ source = remmina-plugin-builder_1.1.0.0.tar.gz::https://github.com/muflone/remmina-plugin-builder/archive/1.1.0.0.tar.gz
+ source = remmina-plugin-exec_1.1.1.0.tar.gz::https://github.com/muflone/remmina-plugin-exec/archive/1.1.1.0.tar.gz
+ sha256sums = 0d41d50731ae25dfa1e66394cfa489d598cf491d36dbaf44d72ad921589e0960
+ sha256sums = 9b15738782488f74a05de07f6fa32f0666a9a5001fc19ecc7b5767cd1261423c
+
+pkgname = remmina-plugin-exec
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee6951bf3e4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=remmina-plugin-exec
+pkgver=1.1.1.0
+pkgrel=2
+_builderver=1.1.0.0
+pkgdesc="A protocol plugin for Remmina to execute an external process."
+arch=('i686' 'x86_64')
+url="http://www.muflone.com/${pkgname}/"
+license=('GPL')
+depends=('gtk3' 'remmina')
+makedepends=('pkg-config' 'cmake')
+install="${pkgname}.install"
+source=("remmina-plugin-builder_${_builderver}.tar.gz::https://github.com/muflone/remmina-plugin-builder/archive/${_builderver}.tar.gz"
+ "${pkgname}_${pkgver}.tar.gz::https://github.com/muflone/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('0d41d50731ae25dfa1e66394cfa489d598cf491d36dbaf44d72ad921589e0960'
+ '9b15738782488f74a05de07f6fa32f0666a9a5001fc19ecc7b5767cd1261423c')
+
+build() {
+ [ -d build ] && rm -rf build
+ cp -r "remmina-plugin-builder-${_builderver}" build
+ cp -r "${pkgname}-${pkgver}"/* "build/remmina-plugin-to-build"
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "${srcdir}/build/"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/remmina-plugin-exec.install b/remmina-plugin-exec.install
new file mode 100644
index 000000000000..a84e858d13e1
--- /dev/null
+++ b/remmina-plugin-exec.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}