summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:23 +0200
committerMuflone2015-06-13 17:59:23 +0200
commit246eef86b54caf3aeb1cea8a33632fb15a6c2271 (patch)
tree43be8e97cb6a50e4cbfeca002e174b6856c6ecfe
downloadaur-246eef86b54caf3aeb1cea8a33632fb15a6c2271.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
-rw-r--r--remmina-plugin-open.install11
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..254d7491bda5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = remmina-plugin-open
+ pkgdesc = A protocol plugin for Remmina to open a document with its associated application.
+ pkgver = 1.1.1.0
+ pkgrel = 2
+ url = http://www.muflone.com/remmina-plugin-open/
+ install = remmina-plugin-open.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkg-config
+ makedepends = cmake
+ depends = gtk3
+ depends = remmina
+ optdepends = xdg-utils: for Automatically detected option
+ optdepends = libgnome: for Open for GNOME option
+ source = remmina-plugin-builder_1.1.0.0.tar.gz::https://github.com/muflone/remmina-plugin-builder/archive/1.1.0.0.tar.gz
+ source = remmina-plugin-open_1.1.1.0.tar.gz::https://github.com/muflone/remmina-plugin-open/archive/1.1.1.0.tar.gz
+ sha256sums = 0d41d50731ae25dfa1e66394cfa489d598cf491d36dbaf44d72ad921589e0960
+ sha256sums = 3801da4e7967dcfafa7ea7032d2d0ae354f4b1627ca98033a9e601e44ea86bd4
+
+pkgname = remmina-plugin-open
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df5e92b7a64a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=remmina-plugin-open
+pkgver=1.1.1.0
+pkgrel=2
+_builderver=1.1.0.0
+pkgdesc="A protocol plugin for Remmina to open a document with its associated application."
+arch=('i686' 'x86_64')
+url="http://www.muflone.com/${pkgname}/"
+license=('GPL')
+depends=('gtk3' 'remmina')
+makedepends=('pkg-config' 'cmake')
+optdepends=(
+ 'xdg-utils: for Automatically detected option'
+ 'libgnome: for Open for GNOME option'
+)
+install="${pkgname}.install"
+source=("remmina-plugin-builder_${_builderver}.tar.gz::https://github.com/muflone/remmina-plugin-builder/archive/${_builderver}.tar.gz"
+ "${pkgname}_${pkgver}.tar.gz::https://github.com/muflone/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('0d41d50731ae25dfa1e66394cfa489d598cf491d36dbaf44d72ad921589e0960'
+ '3801da4e7967dcfafa7ea7032d2d0ae354f4b1627ca98033a9e601e44ea86bd4')
+
+build() {
+ [ -d build ] && rm -rf build
+ cp -r "remmina-plugin-builder-${_builderver}" build
+ cp -r "${pkgname}-${pkgver}"/* "build/remmina-plugin-to-build"
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "${srcdir}/build/"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/remmina-plugin-open.install b/remmina-plugin-open.install
new file mode 100644
index 000000000000..a84e858d13e1
--- /dev/null
+++ b/remmina-plugin-open.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}