summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:23 +0200
committerMuflone2015-06-13 17:59:23 +0200
commit97d656b8d9b60ddfe642cf048cf6c57ef71aeb9a (patch)
treeda7729f1ad25580bf19dd973e728b55b0828ae0d
downloadaur-97d656b8d9b60ddfe642cf048cf6c57ef71aeb9a.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
-rw-r--r--remmina-plugin-rdesktop.install11
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8bc5dc9f7845
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = remmina-plugin-rdesktop
+ pkgdesc = A protocol plugin for Remmina to open a RDP connection with rdesktop.
+ pkgver = 1.1.1.0
+ pkgrel = 2
+ url = http://www.muflone.com/remmina-plugin-rdesktop/
+ install = remmina-plugin-rdesktop.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkg-config
+ makedepends = cmake
+ depends = gtk3
+ depends = remmina
+ depends = rdesktop
+ source = remmina-plugin-builder_1.1.0.0.tar.gz::https://github.com/muflone/remmina-plugin-builder/archive/1.1.0.0.tar.gz
+ source = remmina-plugin-rdesktop_1.1.1.0.tar.gz::https://github.com/muflone/remmina-plugin-rdesktop/archive/1.1.1.0.tar.gz
+ sha256sums = 0d41d50731ae25dfa1e66394cfa489d598cf491d36dbaf44d72ad921589e0960
+ sha256sums = 8e2881a8a481e0db095064230b5c21be2d8b5e809eb5cf36f028916f9c24e164
+
+pkgname = remmina-plugin-rdesktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5eb4bcc53181
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=remmina-plugin-rdesktop
+pkgver=1.1.1.0
+pkgrel=2
+_builderver=1.1.0.0
+pkgdesc="A protocol plugin for Remmina to open a RDP connection with rdesktop."
+arch=('i686' 'x86_64')
+url="http://www.muflone.com/${pkgname}/"
+license=('GPL')
+depends=('gtk3' 'remmina' 'rdesktop')
+makedepends=('pkg-config' 'cmake')
+install="${pkgname}.install"
+source=("remmina-plugin-builder_${_builderver}.tar.gz::https://github.com/muflone/remmina-plugin-builder/archive/${_builderver}.tar.gz"
+ "${pkgname}_${pkgver}.tar.gz::https://github.com/muflone/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('0d41d50731ae25dfa1e66394cfa489d598cf491d36dbaf44d72ad921589e0960'
+ '8e2881a8a481e0db095064230b5c21be2d8b5e809eb5cf36f028916f9c24e164')
+
+build() {
+ [ -d build ] && rm -rf build
+ cp -r "remmina-plugin-builder-${_builderver}" build
+ cp -r "${pkgname}-${pkgver}"/* "build/remmina-plugin-to-build"
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "${srcdir}/build/"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/remmina-plugin-rdesktop.install b/remmina-plugin-rdesktop.install
new file mode 100644
index 000000000000..a84e858d13e1
--- /dev/null
+++ b/remmina-plugin-rdesktop.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}