summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Mashos2020-10-01 15:16:43 -0700
committerThomas Mashos2020-10-01 15:17:26 -0700
commit0c6fac19008a74456bcc7ca45fe136f1c78a9f1b (patch)
tree52c5e692aa9aa93f9d461c2f44ef789ffc2bce41
parent8843c1ddeaf0dc666607ae208a0aa2c88d0f5e22 (diff)
downloadaur-0c6fac19008a74456bcc7ca45fe136f1c78a9f1b.tar.gz
Add cert extraction per https://forum.devolutions.net/topics/34296/problems-registering-rdm-on-linux-closes-at-registration-time
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--remote-desktop-manager.install21
3 files changed, 27 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ace980c025b0..dda84f9cb7e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = remote-desktop-manager
pkgdesc = Devolutions Remote Desktop Manager Enterprise centralizes all remote connections on a single platform that is securely shared between users and across the entire team.
pkgver = 2020.2.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://remotedesktopmanager.com/
+ install = remote-desktop-manager.install
arch = x86_64
license = Proprietary
depends = webkit2gtk
+ depends = p11-kit
options = !strip
source = RemoteDesktopManager_2020.2.4.0_amd64.deb::https://cdn.devolutions.net/download/Linux/RDM/2020.2.4.0/RemoteDesktopManager_2020.2.4.0_amd64.deb
sha256sums = 2b40b621860706546cfb6b3aa1933acbad364068ab692d7ca4709b3ebf521367
diff --git a/PKGBUILD b/PKGBUILD
index ee4086c73983..a8d69d424a5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Thomas Mashos <thomas at mashos dot com>
pkgname=remote-desktop-manager
pkgver=2020.2.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Devolutions Remote Desktop Manager Enterprise centralizes all remote connections on a single platform that is securely shared between users and across the entire team."
arch=('x86_64')
url="https://remotedesktopmanager.com/"
license=('Proprietary')
groups=()
-depends=('webkit2gtk')
+depends=('webkit2gtk' 'p11-kit')
options=(!strip)
+install=${pkgname}.install
source=("RemoteDesktopManager_${pkgver}_amd64.deb::https://cdn.devolutions.net/download/Linux/RDM/${pkgver}/RemoteDesktopManager_${pkgver}_amd64.deb")
sha256sums=('2b40b621860706546cfb6b3aa1933acbad364068ab692d7ca4709b3ebf521367')
diff --git a/remote-desktop-manager.install b/remote-desktop-manager.install
new file mode 100644
index 000000000000..8d8837b61646
--- /dev/null
+++ b/remote-desktop-manager.install
@@ -0,0 +1,21 @@
+# Some colored makepkg-like functions
+msg_blue() {
+ printf "${BLUE}==>${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+note() {
+ printf "${BLUE}==>${ALL_OFF}${YELLOW} NOTE:${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="$(tput bold)"
+BLUE="${BOLD}$(tput setaf 4)"
+YELLOW="${BOLD}$(tput setaf 3)"
+
+post_install() {
+ if [ ! -d "/usr/share/.mono/new-certs/Trust" ]; then
+ msg_blue "Extracting ca-anchors.."
+ mkdir -p /usr/share/.mono/new-certs/Trust
+ trust extract --filter=ca-anchors --format=pem-directory-hash --purpose=server-auth /usr/share/.mono/new-certs/Trust/
+ fi
+} \ No newline at end of file