summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Mashos2020-10-01 15:21:30 -0700
committerThomas Mashos2020-10-01 15:21:30 -0700
commita10f8fd8c729c6c9a7f7716de0ba3e1ccb99b5fb (patch)
treeecdabbe21381630783d4f43fe66a5cbe56298c46
parenta2744003ec469d3fb430f241f283ccd9240f57f0 (diff)
downloadaur-a10f8fd8c729c6c9a7f7716de0ba3e1ccb99b5fb.tar.gz
Extract certificate trust
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--remote-desktop-manager-free.install25
3 files changed, 31 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03fa5a29d42e..35e973e4063e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = remote-desktop-manager-free
pkgdesc = Devolutions Remote Desktop Manager Free centralizes all remote connections on a single platform that is securely shared between users and across the entire team.
pkgver = 2020.2.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://remotedesktopmanager.com/
+ install = remote-desktop-manager-free.install
arch = x86_64
license = Proprietary
depends = webkit2gtk
+ depends = p11-kit
options = !strip
source = RemoteDesktopManager.Free_2020.2.4.0_amd64.deb::https://cdn.devolutions.net/download/Linux/RDM/2020.2.4.0/RemoteDesktopManager.Free_2020.2.4.0_amd64.deb
sha256sums = 83125b1b786b19d713baf44386509ce01753ea4fe4d9423dcd0a8a1e98928e26
diff --git a/PKGBUILD b/PKGBUILD
index fa3d8d8fd9f1..14521151508a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Thomas Mashos <thomas at mashos dot com>
pkgname=remote-desktop-manager-free
pkgver=2020.2.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Devolutions Remote Desktop Manager Free centralizes all remote connections on a single platform that is securely shared between users and across the entire team."
arch=('x86_64')
url="https://remotedesktopmanager.com/"
license=('Proprietary')
groups=()
-depends=('webkit2gtk')
+depends=('webkit2gtk' 'p11-kit')
options=(!strip)
+install=${pkgname}.install
source=("RemoteDesktopManager.Free_${pkgver}_amd64.deb::https://cdn.devolutions.net/download/Linux/RDM/${pkgver}/RemoteDesktopManager.Free_${pkgver}_amd64.deb")
sha256sums=('83125b1b786b19d713baf44386509ce01753ea4fe4d9423dcd0a8a1e98928e26')
diff --git a/remote-desktop-manager-free.install b/remote-desktop-manager-free.install
new file mode 100644
index 000000000000..86586f29d78e
--- /dev/null
+++ b/remote-desktop-manager-free.install
@@ -0,0 +1,25 @@
+# Some colored makepkg-like functions
+msg_blue() {
+ printf "${BLUE}==>${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+note() {
+ printf "${BLUE}==>${ALL_OFF}${YELLOW} NOTE:${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="$(tput bold)"
+BLUE="${BOLD}$(tput setaf 4)"
+YELLOW="${BOLD}$(tput setaf 3)"
+
+post_install() {
+ if [ ! -d "/usr/share/.mono/new-certs/Trust" ]; then
+ msg_blue "Extracting ca-anchors.."
+ mkdir -p /usr/share/.mono/new-certs/Trust
+ trust extract --filter=ca-anchors --format=pem-directory-hash --purpose=server-auth /usr/share/.mono/new-certs/Trust/
+ fi
+}
+
+post_upgrade() {
+ post_install
+} \ No newline at end of file