summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-01-20 14:38:11 +0100
committerPhilip Goto2020-01-20 14:38:11 +0100
commit130f1bfc9cddcf723df75c26ff524d85d08de31b (patch)
tree498429107a963487f24e80c2a34701b98c6102f4
downloadaur-130f1bfc9cddcf723df75c26ff524d85d08de31b.tar.gz
Initialize package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c392db62319
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = remotely
+ pkgdesc = A GTK3 VNC Client
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://gitlab.gnome.org/haecker-felix/Remotely
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ makedepends = meson
+ makedepends = vala
+ depends = gtk-vnc
+ source = https://gitlab.gnome.org/World/Remotely/-/archive/v1.0/Remotely-v1.0.tar.gz
+ md5sums = 35b9d43f36fbb743de7b8819f0981d10
+
+pkgname = remotely
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3193fd71245
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=remotely
+pkgver=1.0
+pkgrel=1
+pkgdesc="A GTK3 VNC Client"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://gitlab.gnome.org/haecker-felix/Remotely"
+license=('GPL3')
+depends=('gtk-vnc')
+makedepends=('meson' 'vala')
+source=("https://gitlab.gnome.org/World/Remotely/-/archive/v${pkgver}/Remotely-v${pkgver}.tar.gz")
+md5sums=('35b9d43f36fbb743de7b8819f0981d10')
+
+
+build() {
+ arch-meson "Remotely-v${pkgver}" build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir/" ninja -C build install
+}