summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLegendOfMiracles2020-04-08 07:35:00 +0200
committerLegendOfMiracles2020-04-08 07:35:00 +0200
commited614890fe1bac356582362e4207d793c33c20f7 (patch)
tree12f82a5e27dd60eb559a7ddb5339fbe928e339e2
downloadaur-ed614890fe1bac356582362e4207d793c33c20f7.tar.gz
first commit
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4fd187ea37b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,10 @@
+pkgbase = remoteplaydetached
+ pkgdesc = A simple launcher that is able to launch any external game or application with Steam Remote Play Together Support
+ pkgver = v0.2.3
+ pkgrel = 1
+ arch = x86_64
+ source = https://github.com/smaTc/RemotePlayDetached/releases/download/v0.2.3/RemotePlayDetached
+ sha256sums = d5c1a29e3183a9a97484ce9bb39e8a87a83b5366abea7c12c49c59f73b366f53
+
+pkgname = remoteplaydetached-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a46566384417
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname='remoteplaydetached-bin'
+pkgbase='remoteplaydetached'
+_pkgname='RemotePlayDetached'
+pkgver=v0.2.3
+pkgrel=1
+pkgdesc='A simple launcher that is able to launch any external game or application with Steam Remote Play Together Support'
+arch=('x86_64')
+source=("https://github.com/smaTc/RemotePlayDetached/releases/download/${pkgver}/RemotePlayDetached")
+sha256sums=('d5c1a29e3183a9a97484ce9bb39e8a87a83b5366abea7c12c49c59f73b366f53')
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ install -Dm0755 "$_pkgname" "$pkgdir"/usr/bin
+
+ curl https://raw.githubusercontent.com/alx365/RemotePlayDetached/master/remoteplaydetached.desktop > remoteplaydetached.desktop
+ sed -i "s#user#${USER}#g" remoteplaydetached.desktop
+ mv remoteplaydetached.desktop ~/.local/share/applications
+
+
+ curl https://raw.githubusercontent.com/alx365/RemotePlayDetached/master/resources/logo.png > remoteplaydetached.png
+
+ mv remoteplaydetached.png ~/.icons/
+
+ curl https://raw.githubusercontent.com/alx365/RemotePlayDetached/master/uninstall.sh > uninstall.sh
+ chmod +x uninstall.sh
+}