summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRojikku2023-03-09 17:20:15 -0500
committerRojikku2023-03-09 17:20:15 -0500
commit48af450086598dd1b7d08226e516abff0290ea7a (patch)
tree41c874d9ae4c4b611daf116b3515181ff6f8019e
downloadaur-48af450086598dd1b7d08226e516abff0290ea7a.tar.gz
Initial release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bada7289e406
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = remoteplaywhatever
+ pkgdesc = Tiny application that lets you force remote play together any game you have in your steam library including non-steam ones.
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/m4dEngi/RemotePlayWhatever
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = libtiff
+ depends = wxwidgets-common
+ depends = wxwidgets-gtk3
+ provides = remoteplaywhatever
+ source = remoteplaywhatever::git+https://github.com/m4dEngi/RemotePlayWhatever.git#tag=0.2.2-alpha
+ sha512sums = SKIP
+
+pkgname = remoteplaywhatever
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08a3fff385e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Rojikku <RojikkuNoKami at gmail dot com>
+pkgname=remoteplaywhatever
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Tiny application that lets you force remote play together any game you have in your steam library including non-steam ones."
+arch=('x86_64')
+url="https://github.com/m4dEngi/RemotePlayWhatever"
+license=('MIT')
+provides=('remoteplaywhatever')
+depends=('libtiff' 'wxwidgets-common' 'wxwidgets-gtk3')
+makedepends=('git' 'cmake')
+source=("${pkgname}::git+${url}.git#tag=${pkgver}-alpha")
+sha512sums=('SKIP')
+
+prepare() {
+ git -C "${pkgname}" submodule update --init --recursive
+}
+
+build() {
+ cmake -B build -S "${pkgname}" -DCMAKE_BUILD_TYPE='Release' -DCMAKE_INSTALL_PREFIX='/usr' -Wno-dev
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+