summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-06 17:50:46 +0800
committerzxp198210052023-09-06 17:50:46 +0800
commit54f779eca00465b5ebcca02c1e28e92bbdeb27e0 (patch)
tree80085a54d9128ba3d5f09e0c59178904e871dfd0
parent13c7944c55cb9370a404a78911298bf4e572608e (diff)
downloadaur-54f779eca00465b5ebcca02c1e28e92bbdeb27e0.tar.gz
fix errors
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ca8b61e9c99..5205b40a5cd2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = remoteplaywhatever-bin
pkgdesc = Tiny application that lets you force remote play together any game you have in your steam library including non-steam ones.
- pkgver = 0.2.3alpha
+ pkgver = 0.2.4
pkgrel = 1
url = https://github.com/m4dEngi/RemotePlayWhatever
arch = x86_64
license = MIT
depends = gcc-libs
depends = glibc
+ provides = remoteplaywhatever=0.2.4
conflicts = remoteplaywhatever
- options = !strip
- source = remoteplaywhatever-0.2.3alpha.deb::https://github.com/m4dEngi/RemotePlayWhatever/releases/download/0.2.3-alpha/RemotePlayWhatever-0.2.3-Linux.deb
- source = LICENSE::https://github.com/m4dEngi/RemotePlayWhatever/raw/master/LICENSE
- sha256sums = 06de4747350c6c2c98457f2d65929242cccc652bfccf5d7240a8c617cbb7b400
+ source = remoteplaywhatever-0.2.4.deb::https://github.com/m4dEngi/RemotePlayWhatever/releases/download/0.2.4-alpha/RemotePlayWhatever-0.2.4-Linux.deb
+ source = LICENSE::https://raw.githubusercontent.com/m4dEngi/RemotePlayWhatever/0.2.4-alpha/LICENSE
+ sha256sums = bccd5e80f2767e3adf83c5fcd31cfa415a97f097c95f9b5a9b22261e2479dccb
sha256sums = 284724acc9bb9b5a0579ca01589605ad6d8b4cd01094d7077ca6308aa5786cdd
pkgname = remoteplaywhatever-bin
diff --git a/PKGBUILD b/PKGBUILD
index 304d0b6627e6..242e8f23dbe4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
# Contributor: Rojikku <RojikkuNoKami at gmail dot com>
pkgname=remoteplaywhatever-bin
-pkgver=0.2.3alpha
+_pkgname=RemotePlayWhatever
+pkgver=0.2.4
pkgrel=1
pkgdesc="Tiny application that lets you force remote play together any game you have in your steam library including non-steam ones."
arch=('x86_64')
license=('MIT')
url="https://github.com/m4dEngi/RemotePlayWhatever"
-provides=()
+provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=('gcc-libs' 'glibc')
-options=(!strip)
-source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/${pkgver%alpha}-alpha/RemotePlayWhatever-${pkgver%alpha}-Linux.deb"
- "LICENSE::${url}/raw/master/LICENSE")
-sha256sums=('06de4747350c6c2c98457f2d65929242cccc652bfccf5d7240a8c617cbb7b400'
+source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/${pkgver}-alpha/${_pkgname}-${pkgver}-Linux.deb"
+ "LICENSE::https://raw.githubusercontent.com/m4dEngi/RemotePlayWhatever/${pkgver}-alpha/LICENSE")
+sha256sums=('bccd5e80f2767e3adf83c5fcd31cfa415a97f097c95f9b5a9b22261e2479dccb'
'284724acc9bb9b5a0579ca01589605ad6d8b4cd01094d7077ca6308aa5786cdd')
+prepare() {
+ bsdtar -xf "${srcdir}/data.tar.gz"
+}
package() {
- bsdtar -xf "${srcdir}/data.tar.gz" -C "${pkgdir}"
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm755 "${srcdir}/usr/bin/${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file