summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRojikku2021-07-18 17:12:25 -0400
committerRojikku2021-07-18 17:12:25 -0400
commitdc314d2f8c480d354458038d28cbde3195bbf9cf (patch)
treeb01f41c0c94f30dbb95e713f089933fbc8d4a4a9
downloadaur-dc314d2f8c480d354458038d28cbde3195bbf9cf.tar.gz
Initial 0.1.10
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dede44e7b444
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = remoteplaywhatever-bin
+ pkgdesc = Tiny application that lets you force remote play together any game you have in your steam library including non-steam ones.
+ pkgver = 0.1.10
+ pkgrel = 1
+ url = https://github.com/m4dEngi/RemotePlayWhatever
+ arch = x86_64
+ depends = wxgtk-common
+ depends = wxgtk3
+ source = remoteplaywhatever-bin-0.1.10.deb::https://github.com/m4dEngi/remoteplaywhatever/releases/download/0.1.10-alpha/remoteplaywhatever-0.1.10-Linux.deb
+ sha512sums = 40594efd1e648c3199f31d79bfcb6379606f83db444106318dd59efe36b00d24c305c67c95b4ed2657dbd9fc34c629d2b1d1a8737c263d4c03c1af30f6b2cacb
+
+pkgname = remoteplaywhatever-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f3041fb2d2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Rojikku <RojikkuNoKami at gmail dot com>
+_pkgname=remoteplaywhatever
+pkgname=${_pkgname}-bin
+pkgver=0.1.10
+pkgrel=1
+pkgdesc="Tiny application that lets you force remote play together any game you have in your steam library including non-steam ones."
+arch=('x86_64')
+url="https://github.com/m4dEngi/RemotePlayWhatever"
+depends=('wxgtk-common' 'wxgtk3')
+source=(
+ ${pkgname}-${pkgver}.deb::https://github.com/m4dEngi/${_pkgname}/releases/download/${pkgver}-alpha/${_pkgname}-${pkgver}-Linux.deb
+)
+sha512sums=('40594efd1e648c3199f31d79bfcb6379606f83db444106318dd59efe36b00d24c305c67c95b4ed2657dbd9fc34c629d2b1d1a8737c263d4c03c1af30f6b2cacb')
+
+prepare() {
+ cd "$srcdir"
+ tar xvf data.tar.gz
+}
+
+package() {
+ cd "$srcdir/usr/bin"
+
+ # binary
+ install -D -m0755 remoteplaywhatever "${pkgdir}/usr/bin/remoteplaywhatever"
+
+}
+