summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlod2025-01-31 16:42:15 +0100
committerlod2025-01-31 16:42:15 +0100
commit6287814fa96706a50acc96cf125e5cd9a6bceedd (patch)
treec5eb8b2c7749b0782f3a0b148d58238b44d267a7
parent18e1b1c94f518d79ae6b2cf94e5af3078d80affb (diff)
downloadaur-6287814fa96706a50acc96cf125e5cd9a6bceedd.tar.gz
switch to tester branch and a patch to build with SDL2-compat
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bbcfd0e271a..6b67b5a55131 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = render96ex-git
pkgdesc = Super Mario 64 PC Port (sm64ex) fork including Render96 Textures and Models
- pkgver = 3.25.r769.cd02b888
+ pkgver = 3.25.r849.61480c4e
pkgrel = 1
url = https://github.com/Render96/Render96ex
arch = x86_64
@@ -8,6 +8,7 @@ pkgbase = render96ex-git
makedepends = git
makedepends = python
makedepends = audiofile
+ makedepends = glu
depends = bash
depends = gcc-libs
depends = glibc
@@ -16,7 +17,7 @@ pkgbase = render96ex-git
depends = sdl2
provides = render96ex
options = !debug
- source = git+https://github.com/Render96/Render96ex.git#branch=alpha
+ source = git+https://github.com/Render96/Render96ex.git#branch=tester
source = git+https://github.com/pokeheadroom/RENDER96-HD-TEXTURE-PACK.git
source = git+https://github.com/Render96/ModelPack.git#branch=models_vanilla
source = https://github.com/Render96/ModelPack/releases/download/3.25/Render96_DynOs_v3.25.7z
diff --git a/PKGBUILD b/PKGBUILD
index b897e5fb31c3..1fc413d3f2fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,18 @@
# The ROM is checksummed to ensure that it is the correct version.
pkgname=render96ex-git
-pkgver=3.25.r769.cd02b888
+pkgver=3.25.r849.61480c4e
pkgrel=1
pkgdesc='Super Mario 64 PC Port (sm64ex) fork including Render96 Textures and Models'
arch=('x86_64')
url='https://github.com/Render96/Render96ex'
license=('Unlicense')
-makedepends=('git' 'python' 'audiofile')
+makedepends=('git' 'python' 'audiofile' 'glu')
depends=('bash' 'gcc-libs' 'glibc' 'hicolor-icon-theme' 'libglvnd' 'sdl2' )
provides=(${pkgname%%-*})
_gitname=${pkgname%%-*} && _gitname=${_gitname^}
options=('!debug')
-source=(git+https://github.com/Render96/Render96ex.git#branch=alpha
+source=(git+https://github.com/Render96/Render96ex.git#branch=tester
git+https://github.com/pokeheadroom/RENDER96-HD-TEXTURE-PACK.git
git+https://github.com/Render96/ModelPack.git#branch=models_vanilla
https://github.com/Render96/ModelPack/releases/download/${pkgver%%.r*}/Render96_DynOs_v${pkgver%%.r*}.7z
@@ -64,6 +64,9 @@ prepare() {
cp -r $srcdir/Render96\ Luigi\ v${pkgver%%.r*} $srcdir/$_gitname/build/us_pc/dynos/packs/
cp -r $srcdir/Render96\ Wario\ v${pkgver%%.r*} $srcdir/$_gitname/build/us_pc/dynos/packs/
cp -r $srcdir/Render96\ Mario\ v${pkgver%%.r*} $srcdir/$_gitname/build/us_pc/dynos/packs/
+
+ # add #include <stdio.h> to these files so it can build with SDL2-compat
+ sed -i '/#include <SDL2\/SDL.h>/a #include <stdio.h>' src/pc/audio/audio_sdl.c src/pc/gfx/gfx_opengl.c
}
build() {