summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandy Carter2017-06-07 13:04:14 -0400
committerSandy Carter2017-06-07 13:04:14 -0400
commita100ed5710caaf4d78597b5775a5cba55cd8d850 (patch)
tree4b2ddc9c643f2943990cb010ee192504e3b6805f
parent64f82706815720a379e446b9dc8b1bcbdc67385f (diff)
downloadaur-a100ed5710caaf4d78597b5775a5cba55cd8d850.tar.gz
update to 0.34
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
-rw-r--r--renderdoc.desktop10
3 files changed, 21 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b84a27cb73ac..0c764e56ce12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,22 @@
-# Generated by mksrcinfo v8
-# Mon Oct 3 11:42:47 UTC 2016
pkgbase = renderdoc
pkgdesc = OpenGL and Vulkan debugging tool
- pkgver = 0.31
+ pkgver = 0.34
pkgrel = 1
url = https://github.com/baldurk/renderdoc
arch = i686
arch = x86_64
license = MIT
makedepends = cmake
- depends = qt5-x11extras
depends = libx11
depends = libxcb
- depends = xcb-util-keysyms
depends = mesa
depends = libgl
depends = qt5-base
- source = https://github.com/baldurk/renderdoc/archive/v0.31.tar.gz
- source = renderdoc.desktop
- sha384sums = 35da8344f486b6d7584056a9be75e31cc8a0ba51dff0c33b7d9a5e18a69a3d7f3babbd83f28d9d3cde92825cb40c5e81
- sha384sums = 965214960726d34efd08d82a879c75e20e49769e5d7c7d996b570f2754f4688a7331267e0a0e2c54dea1eea3c1ad9e38
+ depends = qt5-svg
+ depends = qt5-x11extras
+ depends = xcb-util-keysyms
+ source = https://github.com/baldurk/renderdoc/archive/v0.34.tar.gz
+ sha384sums = 1e507108fd1b4bcbf1161a66095ffa19a38a099fc301fd5ed206769f7609c4da4b45522dd63ad7825bfd523b7c35442a
pkgname = renderdoc
diff --git a/PKGBUILD b/PKGBUILD
index 54c32260ee65..faa277f1c11d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,28 @@
-# Maintainer: Hubert Jarosz <marqin.pl+aur at gmail dot com> PGP: 0xFFECF63C1AAB83FF
-
pkgname=renderdoc
-pkgver=0.31
+pkgver=0.34
pkgrel=1
pkgdesc="OpenGL and Vulkan debugging tool"
arch=(i686 x86_64)
url="https://github.com/baldurk/renderdoc"
license=("MIT")
makedepends=("cmake")
-depends=("qt5-x11extras" "libx11" "libxcb" "xcb-util-keysyms" "mesa" "libgl" "qt5-base")
-source=("https://github.com/baldurk/renderdoc/archive/v$pkgver.tar.gz"
- "$pkgname.desktop")
-sha384sums=("35da8344f486b6d7584056a9be75e31cc8a0ba51dff0c33b7d9a5e18a69a3d7f3babbd83f28d9d3cde92825cb40c5e81"
- "965214960726d34efd08d82a879c75e20e49769e5d7c7d996b570f2754f4688a7331267e0a0e2c54dea1eea3c1ad9e38")
+depends=("libx11" "libxcb" "mesa" "libgl" "qt5-base" "qt5-svg" "qt5-x11extras" "xcb-util-keysyms")
+source=("https://github.com/baldurk/renderdoc/archive/v${pkgver}.tar.gz")
+sha384sums=("1e507108fd1b4bcbf1161a66095ffa19a38a099fc301fd5ed206769f7609c4da4b45522dd63ad7825bfd523b7c35442a")
build() {
- cd $pkgname-$pkgver
-
- export CXX=g++
-
- cmake -DCMAKE_BUILD_TYPE=Release -DENABLE_QRENDERDOC=OFF -Bbuild -H.
- make -C build
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_VERSION_STABLE=ON \
+ -DBUILD_VERSION_DIST_CONTACT="https://aur.archlinux.org/packages/renderdoc" \
+ -DBUILD_VERSION_DIST_NAME="Arch" \
+ -B"${srcdir}/${pkgname}-${pkgver}"/build \
+ -H"${srcdir}/${pkgname}-${pkgver}"
+ cmake --build "${srcdir}/${pkgname}-${pkgver}"/build
}
package() {
- #install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
- cd $pkgname-$pkgver/build/bin
- install -Dm644 librenderdoc.so "$pkgdir/usr/lib/librenderdoc.so"
- #install -Dm755 qrenderdoc "$pkgdir/usr/bin/qrenderdoc"
- install -Dm755 renderdoccmd "$pkgdir/usr/bin/renderdoccmd"
- cd ../..
- install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
- cd docs/imgs
- install -Dm644 logo.png "$pkgdir/usr/share/icons/$pkgname.png"
+ make DESTDIR="${pkgdir}" -C "${srcdir}/${pkgname}-${pkgver}"/build install
}
+
+# vim:set ts=2 sw=2 et:
diff --git a/renderdoc.desktop b/renderdoc.desktop
deleted file mode 100644
index 292a724dbaf5..000000000000
--- a/renderdoc.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Type=Application
-Name=QRenderDoc
-Comment=RenderDoc is a stand-alone graphics debugging tool.
-Exec=qrenderdoc
-Icon=renderdoc
-Terminal=false
-StartupNotify=false
-Categories=Application;Graphics;Development;