summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack Random2019-09-03 18:45:05 +0200
committerJack Random2019-09-03 18:46:56 +0200
commit26110ce46fed401003406a50364f30819652dbf5 (patch)
tree7048b9c74d26538499da84457361424bf2ed1d7d
parent6f28a2dd645c1f549b62dfd5b9f51a9c67aa2f19 (diff)
downloadaur-26110ce46fed401003406a50364f30819652dbf5.tar.gz
Update to 3.2.0
Refactor PKGBUILD (see renoise package) Remove 32-bit references (3.2.0 is 64-bit only)
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD40
2 files changed, 18 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d89cd2c6886..b8797cf0d38c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = renoise3-demo
pkgdesc = A music composition program
- pkgver = 3.1.0
- pkgrel = 2
+ pkgver = 3.2.0
+ pkgrel = 1
url = http://www.renoise.com
- arch = i686
arch = x86_64
license = custom:renoise
makedepends = xdg-utils
@@ -13,8 +12,8 @@ pkgbase = renoise3-demo
optdepends = jack: For JACK audio support
conflicts = renoise
options = !strip
- source = http://files.renoise.com/demo/Renoise_3_1_0_Demo_x86_64.tar.bz2
- md5sums = 563585735b7bb8db2b3a974d4263aa2a
+ source = https://files.renoise.com/demo/Renoise_3_2_0_Demo_Linux.tar.gz
+ sha256sums = 114ae91c0ffa202bfc0a689774717fcb96ba9a77e234326d30bfb530efffcc31
-pkgname = renoise3-demo
+pkgname = renoise-demo
diff --git a/PKGBUILD b/PKGBUILD
index 80dc9066133a..98493eb28c29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@
# berkus <berkus@madfire.net>
# hm_b <holger@music-nerds.net>
-pkgname="renoise3-demo"
-pkgver="3.1.0"
-pkgrel="2"
+pkgname="renoise-demo"
+pkgver="3.2.0"
+pkgrel="1"
pkgdesc="A music composition program"
-arch=("i686" "x86_64")
+arch=("x86_64")
url="http://www.renoise.com"
license=("custom:renoise")
depends=("alsa-lib" "libx11" "gcc-libs")
@@ -20,33 +20,19 @@ makedepends=("xdg-utils")
options=("!strip")
conflicts=("renoise")
-# This blurb checks if the host machine is x86 or x86_64,
-# then declares the $md5sums and $source arrays accordingly.
-if [[ $CARCH = "x86_64" ]]; then
- if64="_64"
- md5sums=('563585735b7bb8db2b3a974d4263aa2a')
-else
- md5sums=('923e2dc22ad895e474a4dbb9da216b2b')
-fi
-source=("http://files.renoise.com/demo/Renoise_${pkgver//./_}_Demo_x86$if64.tar.bz2")
-
+source=("https://files.renoise.com/demo/Renoise_${pkgver//./_}_Demo_Linux.tar.gz")
+sha256sums=("114ae91c0ffa202bfc0a689774717fcb96ba9a77e234326d30bfb530efffcc31")
package() {
- cd "$srcdir/Renoise_${pkgver//./_}_Demo_x86$if64"
+ cd "$srcdir/Renoise_${pkgver//./_}_Demo_Linux"
mkdir -p "$pkgdir/usr/share/renoise-$pkgver"
cp -r "Resources"/* "$pkgdir/usr/share/renoise-$pkgver"
- install -Dm 755 "renoise" "$pkgdir/usr/bin/renoise3"
- install -Dm 644 "Resources/Skin/Icons/WindowIcon16.png" "$pkgdir/usr/share/icons/hicolor/16x16/apps/renoise3.png"
- install -Dm 644 "Resources/Skin/Icons/WindowIcon32.png" "$pkgdir/usr/share/icons/hicolor/32x32/apps/renoise3.png"
- install -Dm 644 "Resources/Skin/Icons/WindowIcon48.png" "$pkgdir/usr/share/icons/hicolor/48x48/apps/renoise3.png"
- install -Dm 644 "Resources/Skin/Icons/WindowIcon128.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/renoise3.png"
- install -Dm 644 "Resources/Skin/Icons/WindowIcon256.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/renoise3.png"
-
- install -Dm 644 "Installer/renoise.desktop" "$pkgdir/usr/share/applications/renoise3.desktop"
- sed -i 's/=renoise/=renoise3/g' "$pkgdir/usr/share/applications/renoise3.desktop"
- install -Dm 644 "Installer/renoise.1.gz" "$pkgdir/usr/share/man/man1/renoise3.1.gz"
- install -Dm 644 "Installer/renoise-pattern-effects.5.gz" "$pkgdir/usr/share/man/man5/renoise3-pattern-effects.5.gz"
+ install -Dm 755 "renoise" "$pkgdir/usr/bin/renoise"
+ install -Dm 644 "Installer/renoise.desktop" "$pkgdir/usr/share/applications/renoise.desktop"
+ install -Dm 644 "Installer/renoise.1.gz" "$pkgdir/usr/share/man/man1/renoise.1.gz"
+ install -Dm 644 "Installer/renoise-pattern-effects.5.gz" "$pkgdir/usr/share/man/man5/renoise-pattern-effects.5.gz"
install -Dm 644 "License.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
+ install -Dm 644 "Installer/renoise.xml" "$pkgdir/usr/share/mime/packages/renoise.xml"
+} \ No newline at end of file