summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Potier2015-08-12 02:30:14 +0200
committerMartin Potier2015-08-12 02:30:14 +0200
commitd29e6461d6d7dd619d94cac50319bd6377e3f9eb (patch)
treef05ab84c9ac629618375d0a976807fc79c2d4166
downloadaur-d29e6461d6d7dd619d94cac50319bd6377e3f9eb.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..524df3c2cd47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = renoise3-demo
+ pkgdesc = A music composition program
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = http://www.renoise.com
+ arch = i686
+ arch = x86_64
+ license = custom:renoise
+ makedepends = xdg-utils
+ depends = alsa-lib
+ depends = libx11
+ depends = gcc-libs
+ optdepends = jack: For JACK audio support
+ optdepends = jack2: For JACK2 audio support
+ options = !strip
+ source = http://files.renoise.com/demo/Renoise_3_0_1_Demo_x86.tar.bz2
+ md5sums = e58958e8634c13a8291ce33e9b11c643
+
+pkgname = renoise3-demo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c81b463199a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Samæ <eeva.samæ@marvid.fr>
+# Previous maintainer: Kristaps Karlsons <kristaps.karlsons@gmail.com>
+
+# Original contributors (renoise-demo):
+# Max Pray a.k.a. Synthead <synthead@gmail.com>
+# berkus <berkus@madfire.net>
+# hm_b <holger@music-nerds.net>
+
+pkgname="renoise3-demo"
+pkgver="3.0.1"
+pkgrel="1"
+pkgdesc="A music composition program"
+arch=("i686" "x86_64")
+url="http://www.renoise.com"
+license=("custom:renoise")
+depends=("alsa-lib" "libx11" "gcc-libs")
+optdepends=("jack: For JACK audio support"
+ "jack2: For JACK2 audio support")
+makedepends=("xdg-utils")
+options=("!strip")
+
+# This blurb checks if the host machine is x86 or x86_64,
+# then declares the $md5sums and $source arrays accordingly.
+if [[ $CARCH = "x86_64" ]]; then
+ if64="_64"
+ md5sums=('9fe1467691af0a869a5c5d4d0be51023')
+else
+ md5sums=('e58958e8634c13a8291ce33e9b11c643')
+fi
+source=("http://files.renoise.com/demo/Renoise_${pkgver//./_}_Demo_x86$if64.tar.bz2")
+
+package() {
+ cd "$srcdir/Renoise_${pkgver//./_}_Demo_x86$if64"
+
+ mkdir -p "$pkgdir/usr/share/renoise-$pkgver"
+ cp -r "Resources"/* "$pkgdir/usr/share/renoise-$pkgver"
+
+ install -Dm 755 "renoise" "$pkgdir/usr/bin/renoise3"
+ install -Dm 644 "Installer/renoise.png" "$pkgdir/usr/share/icons/hicolor/48x48/apps/renoise3.png"
+ install -Dm 644 "Installer/renoise.desktop" "$pkgdir/usr/share/applications/renoise3.desktop"
+ sed -i 's/=renoise/=renoise3/g' "$pkgdir/usr/share/applications/renoise3.desktop"
+ install -Dm 644 "Installer/renoise.1.gz" "$pkgdir/usr/share/man/man1/renoise3.1.gz"
+ install -Dm 644 "Installer/renoise-pattern-effects.5.gz" "$pkgdir/usr/share/man/man5/renoise3-pattern-effects.5.gz"
+ install -Dm 644 "License.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}