summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2024-06-12 19:50:24 -0400
committerPatrick Northon2024-06-12 19:50:24 -0400
commit3e88a5f4b5ebcfa10e6feb2a26abd213e325b9dc (patch)
tree3b69e83acfa08ce08299d24fbfbf3d35785afe49
parent43bb5089665cfb029acadd0083267358dbe21bad (diff)
downloadaur-3e88a5f4b5ebcfa10e6feb2a26abd213e325b9dc.tar.gz
Update version.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ccbc93003792..ca4406c0c6e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = renpy
pkgdesc = Visual novel engine Ren'Py along with its platdeps libs
- pkgver = 8.2.1
- pkgrel = 2
+ pkgver = 8.2.2
+ pkgrel = 1
url = http://www.renpy.org
install = renpy.install
arch = i686
@@ -32,10 +32,10 @@ pkgbase = renpy
depends = python-ecdsa
provides = python-renpy
replaces = renpy64
- source = git+https://github.com/renpy/renpy.git#commit=1a30d4dd8eb5d0f21ac8550703439db05fde0cc8
+ source = git+https://github.com/renpy/renpy.git#commit=db12aca24b913a983ee3ac8a171c82b58005b223
source = renpy.desktop
source = renpy-launcher.sh
- sha256sums = SKIP
+ sha256sums = 551d595e30be55e73037a5d537cab0118cbb8e5c159bd90f74734107fe4bba7e
sha256sums = b58efcc42526c4de15e8963b02991e558b5e3d15d720b3777b791ac13fc815e6
sha256sums = a38112859bf659d48c30be5c7c20ed1a1c72271ffd74eb4b4e730afbd87d73dc
diff --git a/PKGBUILD b/PKGBUILD
index fd63b5c206de..ae5068effaf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
pkgname=renpy
-pkgver=8.2.1
-_commit=1a30d4dd8eb5d0f21ac8550703439db05fde0cc8
-pkgrel=2
+pkgver=8.2.2
+_commit=db12aca24b913a983ee3ac8a171c82b58005b223
+pkgrel=1
pkgdesc="Visual novel engine Ren'Py along with its platdeps libs"
arch=('i686' 'x86_64')
license=('MIT')
url='http://www.renpy.org'
depends=(
'glibc' 'ffmpeg' 'fribidi' 'harfbuzz' 'freetype2' 'libpng'
- 'python-pygame-sdl2' 'sdl2' 'sdl2_image' 'sdl2_mixer'
+ 'python-pygame-sdl2' 'sdl2' 'sdl2_image' 'sdl2_mixer'
'sdl2_gfx' 'sdl2_ttf' 'python-future' 'python-ecdsa')
makedepends=(
- 'cython0' 'python-setuptools-scm' 'python-sphinx' 'python-sphinx_rtd_dark_mode'
+ 'cython0' 'python-setuptools-scm' 'python-sphinx' 'python-sphinx_rtd_dark_mode'
'python-sphinx_rtd_theme' 'python-build' 'python-installer' 'python-wheel' 'git')
provides=('python-renpy')
replaces=('renpy64')
@@ -22,7 +22,7 @@ install='renpy.install'
source=("git+https://github.com/${pkgname}/${pkgname}.git#commit=${_commit}"
"${pkgname}.desktop"
"${pkgname}-launcher.sh")
-sha256sums=('SKIP'
+sha256sums=('551d595e30be55e73037a5d537cab0118cbb8e5c159bd90f74734107fe4bba7e'
'b58efcc42526c4de15e8963b02991e558b5e3d15d720b3777b791ac13fc815e6'
'a38112859bf659d48c30be5c7c20ed1a1c72271ffd74eb4b4e730afbd87d73dc')
@@ -34,11 +34,11 @@ build() {
rm -rf "$srcdir/tempinstall"
python -m installer --destdir="$srcdir/tempinstall" dist/*.whl
popd
-
+
# build docs
#cd 'sphinx'
#mkdir -p 'source/inc'
-
+
#local python_version="$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
#PYTHONPATH="$srcdir/tempinstall/usr/lib/python${python_version}/site-packages" python ../renpy.py .
#RENPY_NO_FIGURES=1 sphinx-build -E -a source ../doc -j ${SPHINX_JOBS:-auto}
@@ -46,7 +46,7 @@ build() {
package() {
depends+=('python-pefile' 'python-requests' 'python-rsa' 'python-six')
-
+
#pack data
mkdir -p "$pkgdir/usr/share/$pkgname"
@@ -58,7 +58,7 @@ package() {
#cp -r doc/* "$pkgdir/usr/share/doc/$pkgname"
install -D -m644 'launcher/game/images/logo.png' "$pkgdir/usr/share/pixmaps/${pkgname}.png"
install -D -m644 'sphinx/source/license.rst' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
+
install -d -m755 "$pkgdir/usr/share/renpy/lib/py3-linux-x86_64"
ln -s '/usr/bin/renpy' "$pkgdir/usr/share/renpy/lib/py3-linux-x86_64"