summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-11-23 21:13:50 +0100
committerhaawda2018-11-23 21:13:50 +0100
commit64cfd13bc47c2d1cca725af995282e5f6b866f62 (patch)
treedc7bdbfb50818b5203b332d1d855219b6dc87f14
parentd1290b93bb6286244a20b53e8962a645e5706a71 (diff)
downloadaur-64cfd13bc47c2d1cca725af995282e5f6b866f62.tar.gz
avoid _gitname variable
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da4f021fd2da..636c5287c1ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,15 +14,14 @@ options=('!libtool')
options=('libtool')
source=(git://github.com/SawfishWM/rep-gtk.git)
md5sums=('SKIP')
-_gitname=rep-gtk
pkgver() {
- cd $_gitname
+ cd ${pkgname%-git}
echo $(git describe --tags |sed 's/-/./g'|cut -c9-)
}
build() {
- cd $_gitname
+ cd ${pkgname%-git}
./autogen.sh
./configure --prefix=/usr
@@ -30,6 +29,6 @@ build() {
}
package() {
- cd $_gitname
- make DESTDIR="${pkgdir}" install
+ cd ${pkgname%-git}
+ make DESTDIR="$pkgdir" install
}