summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:34:52 +0200
committerStefan Husmann2015-06-09 00:34:52 +0200
commita6917279b9e21e8d8d654b0e968f66c6f63081b3 (patch)
treeffcbc0fe411b57aab623176dfa8f81ffe62be79f
downloadaur-a6917279b9e21e8d8d654b0e968f66c6f63081b3.tar.gz
initial version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c240dd4fc3d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rep-gtk-git
+ pkgdesc = Binding of the GTK and GDK libraries for the librep Lisp environment - git version
+ pkgver = 0.90.8.2.1.g74ac350
+ pkgrel = 1
+ url = http://rep-gtk.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = librep
+ depends = gtk2
+ provides = rep-gtk=0.90.8.1
+ conflicts = rep-gtk
+ options = libtool
+ source = git://github.com/SawfishWM/rep-gtk.git
+ md5sums = SKIP
+
+pkgname = rep-gtk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e9a3abc42a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=rep-gtk-git
+pkgver=0.90.8.2.1.g74ac350
+pkgrel=1
+pkgdesc="Binding of the GTK and GDK libraries for the librep Lisp environment - git version"
+arch=('i686' 'x86_64')
+url="http://rep-gtk.sourceforge.net/"
+license=('GPL')
+depends=('librep' 'gtk2')
+conflicts=('rep-gtk')
+provides=('rep-gtk=0.90.8.1')
+options=('!libtool')
+options=('libtool')
+source=(git://github.com/SawfishWM/rep-gtk.git)
+md5sums=('SKIP')
+_gitname=rep-gtk
+
+pkgver() {
+ cd $_gitname
+ echo $(git describe --tags |sed 's/-/./g'|cut -c9-)
+}
+
+build() {
+ cd $_gitname
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR="${pkgdir}" install
+}