summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonny2015-08-06 13:12:26 +0200
committerRonny2015-08-06 13:12:26 +0200
commit3aa2b5403dce36b5fa083bcacb80ba8a1e0985b1 (patch)
tree7b6ca89458483efbcc03b406014780db0119fbbd
downloadaur-3aa2b5403dce36b5fa083bcacb80ba8a1e0985b1.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD71
-rw-r--r--repetier-host.install14
3 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7cd2c789ade
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = repetier-host
+ pkgdesc = almost complete 3d-printing workflow
+ pkgver = 1.0.6
+ pkgrel = 3
+ url = http://www.repetier.com/
+ install = repetier-host.install
+ arch = x86_64
+ arch = i686
+ license = custom
+ depends = mono>=3.2.0
+ optdepends = slic3r
+ optdepends = skeinforge
+ source = http://www.repetier.com/w/?wpdmdl=1785
+ source = repetier-host.install
+ md5sums = aa5898b3998896ac6bb39146ef54c5ea
+ md5sums = 3bf735df87c6f3b9e807bbc82edd7a05
+
+pkgname = repetier-host
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fc41b6ae797
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Somebody <somebody[at]foo[dot]tld>
+pkgname=repetier-host
+pkgver=1.0.6
+pkgrel=3
+pkgdesc="almost complete 3d-printing workflow"
+url=('http://www.repetier.com/')
+arch=('x86_64' 'i686')
+license=('custom')
+depends=('mono>=3.2.0')
+optdepends=('slic3r' 'skeinforge')
+source=("http://www.repetier.com/w/?wpdmdl=1785" "$pkgname.install")
+PKGEXT=".pkg.tar"
+install=$pkgname.install
+
+build() {
+cd ${srcdir}/RepetierHost/
+DIR=/usr/share/repetierHost
+
+OSBIT=`uname -m`
+echo "System: ${OSBIT}"
+if [ ${OSBIT} = "i686" ]; then
+echo "Using 32 bit CuraEngine"
+ cp plugins/CuraEngine/CuraEngine32 plugins/CuraEngine/CuraEngine
+else
+echo "Using 64 bit CuraEngine"
+ cp plugins/CuraEngine/CuraEngine64 plugins/CuraEngine/CuraEngine
+fi
+
+echo "#!/bin/sh" > repetierHost
+echo "cd ${DIR}" >> repetierHost
+echo "mono RepetierHost.exe -home ${DIR}&" >> repetierHost
+chmod 755 repetierHost
+chmod a+rx ../RepetierHost
+chmod -R a+r *
+chmod -R a+x data
+chmod a+x installDep*
+rm configureFirst.sh
+rm installDependenciesDebian
+rm installDependenciesFedora
+rm createDesktopIcon.sh
+g++ SetBaudrate.cpp -o SetBaudrate
+
+echo "[Desktop Entry]
+Name=Repetier-Host
+Exec=mono RepetierHost.exe -home $dir&
+Type=Application
+StartupNotify=true
+Comment=Repetier-Host 3d printer host software
+Path=$dir
+Icon=$dir/repetier-logo.png
+Comment[en_US.UTF-8]=Repetier Host
+Name[en_US]=Repetier-Host
+" >> ${srcdir}/Repetier-Host.desktop
+chmod +x ${srcdir}/Repetier-Host.desktop
+
+}
+
+package() {
+mkdir -p $pkgdir/usr/share/
+mkdir -p $pkgdir/usr/bin
+ln -s /usr/share/repetierHost/repetierHost $pkgdir/usr/bin/repetierHost
+
+install -Dm644 ${srcdir}/RepetierHost/Repetier-Host-licence.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+rm ${srcdir}/RepetierHost/Repetier-Host-licence.txt
+cp -a ${srcdir}/RepetierHost $pkgdir/usr/share/repetierHost
+install -Dm755 ${srcdir}/Repetier-Host.desktop $pkgdir/usr/share/applications/Repetier-Host.desktop
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('aa5898b3998896ac6bb39146ef54c5ea'
+ '3bf735df87c6f3b9e807bbc82edd7a05')
diff --git a/repetier-host.install b/repetier-host.install
new file mode 100644
index 000000000000..9a76b4060948
--- /dev/null
+++ b/repetier-host.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo "IMPORTANT: In addition to the bundled CuraEngine, the host also"
+ echo "supports Slic3r and Skeinforge. These slicers are not bundled, so"
+ echo "need to install them according to their docs and then set the path"
+ echo "to them in Repetier-Host."
+}
+post_upgrade() {
+ echo "IMPORTANT: In addition to the bundled CuraEngine, the host also"
+ echo "supports Slic3r and Skeinforge. These slicers are not bundled anymore, so"
+ echo "need to install them according to their docs and then set the path"
+ echo "to them in Repetier-Host."
+ echo This is the version 1.0.6. It now features CuraEngine and has many changes to better work with multi-extruder setups and much more. After installing the new version, old versions might no longer run, unless you delete the registry entries under:
+ echo \$HOME/.mono/registry/CurrentUser/software/ repetierSoftware/repetier
+}