summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422018-03-09 23:05:37 +0100
committerSkycoder422018-03-09 23:05:37 +0100
commit2f7dc5467e2671215f015765741fa08ef04f2382 (patch)
tree89ce48e237b4d99656c20409eba6793f4e0b95b8
parent000200a8c589dba7246af447342673d1467b79b2 (diff)
downloadaur-2f7dc5467e2671215f015765741fa08ef04f2382.tar.gz
updated to 1.2.0
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD5
3 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a95dd114ba58..b7b0a8943713 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = repkg
pkgdesc = A tool to manage rebuilding of AUR packages based on their dependencies
- pkgver = 1.1.0
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/Skycoder42/repkg
arch = i686
@@ -11,8 +11,8 @@ pkgbase = repkg
makedepends = qpmx-qpmsource
depends = qt5-base
depends = pacman
- optdepends = pacaur: Adds support for synchronizing AUR packages
- source = repkg-1.1.0::git+https://github.com/Skycoder42/repkg.git#tag=1.1.0
+ optdepends = trizen: The recommended frontend for the AUR to use with repkg
+ source = repkg-1.2.0::git+https://github.com/Skycoder42/repkg.git#tag=1.2.0
source = repkg.rule
sha256sums = SKIP
sha256sums = f4b9afd13da458db0ad55e8e1e99565a6485fc60a7745ad816f01f816e5bee22
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
index cdc0716fe9e1..3d56c67b00ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Felix Barz <skycoder42.de@gmx.de>
pkgname=repkg
-pkgver=1.1.0
+pkgver=1.2.0
pkgrel=1
pkgdesc="A tool to manage rebuilding of AUR packages based on their dependencies"
arch=('i686' 'x86_64')
@@ -8,7 +8,7 @@ url="https://github.com/Skycoder42/$pkgname"
license=('BSD')
depends=('qt5-base' 'pacman' )
makedepends=('qt5-tools' 'git' 'qpmx-qpmsource')
-optdepends=("pacaur: Adds support for synchronizing AUR packages")
+optdepends=("trizen: The recommended frontend for the AUR to use with repkg")
source=("$pkgname-$pkgver::git+https://github.com/Skycoder42/$pkgname.git#tag=$pkgver"
"$pkgname.rule")
sha256sums=('SKIP'
@@ -32,6 +32,7 @@ package() {
cd "../$pkgname-$pkgver"
install -D -m644 ${pkgname}.hook "$pkgdir/usr/share/libalpm/hooks/${pkgname}.hook"
install -D -m755 ${pkgname}.sh "$pkgdir/usr/share/libalpm/scripts/${pkgname}.sh"
+ install -D -m644 completitions/bash/${pkgname} "$pkgdir/usr/share/bash-completion/completions//${pkgname}"
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"