summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422017-07-31 21:57:06 +0200
committerSkycoder422017-07-31 21:57:06 +0200
commita2765ba896914ff2a624245f15f689f9f9151419 (patch)
treee3d9081f8878cc920f2aa95878cf78aaff5cb560
downloadaur-a2765ba896914ff2a624245f15f689f9f9151419.tar.gz
create AUR package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
-rw-r--r--repkg.rule1
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0ad6f7e2004
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = repkg
+ pkgdesc = A tool to manage rebuilding of AUR packages based on their dependencies
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Baum42/repkg
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = qt5-tools
+ makedepends = git
+ depends = qt5-base
+ depends = pacman
+ optdepends = pacaur: Adds support for synchronizing AUR packages
+ source = repkg-1.0.0::git+https://github.com/Skycoder42/repkg.git#tag=1.0.0
+ source = repkg.rule
+ sha256sums = SKIP
+ sha256sums = f4b9afd13da458db0ad55e8e1e99565a6485fc60a7745ad816f01f816e5bee22
+
+pkgname = repkg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8bc7fe76ab6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Felix Barz <skycoder42.de@gmx.de>
+pkgname=repkg
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A tool to manage rebuilding of AUR packages based on their dependencies"
+arch=('i686' 'x86_64')
+url="https://github.com/Baum42/$pkgname"
+license=('BSD')
+depends=('qt5-base' 'pacman' )
+makedepends=('qt5-tools' 'git')
+optdepends=("pacaur: Adds support for synchronizing AUR packages")
+source=("$pkgname-$pkgver::git+https://github.com/Skycoder42/$pkgname.git#tag=$pkgver"
+ "$pkgname.rule")
+sha256sums=('SKIP'
+ 'f4b9afd13da458db0ad55e8e1e99565a6485fc60a7745ad816f01f816e5bee22')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ qmake -r "../$pkgname-$pkgver/$pkgname.pro"
+ make
+}
+
+package() {
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
+
+ cd "../$pkgname-$pkgver"
+ install -D -m644 ${pkgname}.hook "$pkgdir/usr/share/libalpm/hooks/${pkgname}.hook"
+ install -D -m755 ${pkgname}.sh "$pkgdir/usr/share/libalpm/scripts/${pkgname}.sh"
+
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/${pkgname}.rule"
+}
diff --git a/repkg.rule b/repkg.rule
new file mode 100644
index 000000000000..510d09ba2642
--- /dev/null
+++ b/repkg.rule
@@ -0,0 +1 @@
+qt5-base