summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryo2019-04-05 17:57:46 +0200
committeryo2019-04-05 17:57:46 +0200
commit86204c789d77f8db4d8d845b9d700f11da700879 (patch)
tree33bc432dda4a4d5be8b3d29fc8d73bdee2a2e02b
parentc59099b84e57b8296fc276a7bb7fc512ac2939da (diff)
downloadaur-86204c789d77f8db4d8d845b9d700f11da700879.tar.gz
changing replace entry point to replacefs
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1358772427d..2a2098b2dff6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = replace
pkgdesc = Search and replace tool for strings on the all system
- pkgver = 1.0.4
+ pkgver = 1.0.15
pkgrel = 1
url = https://github.com/yoarch/replace
arch = any
@@ -8,8 +8,8 @@ pkgbase = replace
makedepends = python
makedepends = python-setuptools
depends = python>=3
- source = https://files.pythonhosted.org/packages/source/r/replacefs/replacefs-1.0.4.tar.gz
- sha256sums = 5712f2e30089bb25db79b97c6e6d74a80b03d8d96e2dd3e89a52dc7d603d3d73
+ source = https://files.pythonhosted.org/packages/source/r/replacefs/replacefs-1.0.15.tar.gz
+ sha256sums = 2dbc1b0450f767b5b038bfe4d99b97a31ffb31f0bc44f0c98d9d87cad1dff5e9
pkgname = replace
diff --git a/PKGBUILD b/PKGBUILD
index 0095090a372b..4e323c3f4499 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Yann Orieult <yo.managements@gmail.com>
pkgname=replace
-pkgver='1.0.4'
+pkgver='1.0.15'
pkgrel='1'
pkgdesc='Search and replace tool for strings on the all system'
arch=('any')
@@ -10,9 +10,10 @@ license=('MIT')
depends=('python>=3')
makedepends=('python' 'python-setuptools')
-source=('https://files.pythonhosted.org/packages/source/r/replacefs/replacefs-1.0.4.tar.gz')
-#source=('https://files.pythonhosted.org/packages/06/25/7c9d2578d49b6ff55d1990b5c669c1079e1a15db40ce9318f22498299ec5/replacefs-1.0.4.tar.gz')
-sha256sums=('5712f2e30089bb25db79b97c6e6d74a80b03d8d96e2dd3e89a52dc7d603d3d73')
+source=('https://files.pythonhosted.org/packages/source/r/replacefs/replacefs-1.0.15.tar.gz')
+#source#=("file:///$MHOME/dev/python/replacefs/dist/replacefs-1.0.15.tar.gz")
+sha256sums=('2dbc1b0450f767b5b038bfe4d99b97a31ffb31f0bc44f0c98d9d87cad1dff5e9')
+#sha256sums#=('SKIP')
build() {
cd $srcdir/replacefs-${pkgver}
@@ -24,8 +25,6 @@ package() {
python setup.py install --root="$pkgdir/" --optimize=1
- # license
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- #mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
- #install -m 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 README.md "$pkgdir/usr/lib/$pkgname/README.md"
}