summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryo2019-04-04 17:11:24 +0200
committeryo2019-04-04 17:11:24 +0200
commitc59099b84e57b8296fc276a7bb7fc512ac2939da (patch)
treeebd4518a0f1be3e75ae153d3b1251eb2834bbcb5
downloadaur-c59099b84e57b8296fc276a7bb7fc512ac2939da.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD31
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1358772427d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = replace
+ pkgdesc = Search and replace tool for strings on the all system
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/yoarch/replace
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python>=3
+ source = https://files.pythonhosted.org/packages/source/r/replacefs/replacefs-1.0.4.tar.gz
+ sha256sums = 5712f2e30089bb25db79b97c6e6d74a80b03d8d96e2dd3e89a52dc7d603d3d73
+
+pkgname = replace
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6a9b954b0ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0095090a372b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Yann Orieult <yo.managements@gmail.com>
+
+pkgname=replace
+pkgver='1.0.4'
+pkgrel='1'
+pkgdesc='Search and replace tool for strings on the all system'
+arch=('any')
+url='https://github.com/yoarch/replace'
+license=('MIT')
+depends=('python>=3')
+makedepends=('python' 'python-setuptools')
+
+source=('https://files.pythonhosted.org/packages/source/r/replacefs/replacefs-1.0.4.tar.gz')
+#source=('https://files.pythonhosted.org/packages/06/25/7c9d2578d49b6ff55d1990b5c669c1079e1a15db40ce9318f22498299ec5/replacefs-1.0.4.tar.gz')
+sha256sums=('5712f2e30089bb25db79b97c6e6d74a80b03d8d96e2dd3e89a52dc7d603d3d73')
+
+build() {
+ cd $srcdir/replacefs-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/replacefs-${pkgver}
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ # license
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ #mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ #install -m 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}"
+}